Avro
  1. Avro
  2. AVRO-1068

Avro Java does not build on recent Eclipse versions with m2eclipse

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: 1.7.0
    • Component/s: java
    • Labels:
      None

      Description

      It is so because, in the recent versions of m2eclipse require manual mapping of non-standard maven lifecycle tasks. The forthcoming fix addresses that problem.

      1. AVRO-1068.patch
        2 kB
        Thiruvalluvan M. G.

        Activity

        Hide
        Thiruvalluvan M. G. added a comment -

        This patch ensures that the current versions of Eclipse do not complain. Since the changes are in plugnManagement section of pom.xml there is has no impact if Eclipse is not used or when older versions of Eclipse/m2eclipse are used.

        Show
        Thiruvalluvan M. G. added a comment - This patch ensures that the current versions of Eclipse do not complain. Since the changes are in plugnManagement section of pom.xml there is has no impact if Eclipse is not used or when older versions of Eclipse/m2eclipse are used.
        Hide
        Scott Carey added a comment -

        +1 looks good.

        Show
        Scott Carey added a comment - +1 looks good.
        Hide
        Thiruvalluvan M. G. added a comment -

        Committed revision 1328865.

        Thanks Scott for reviewing it.

        Show
        Thiruvalluvan M. G. added a comment - Committed revision 1328865. Thanks Scott for reviewing it.

          People

          • Assignee:
            Thiruvalluvan M. G.
            Reporter:
            Thiruvalluvan M. G.
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development