Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-4526

[Regression] When a kafka topic is created atlas response does not contail replicationFactor

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • None
    • atlas-core
    • None

    Description

      When a kafka topic is created, and when it reflected in Atlas, the response does not contain 'replicationFactor'

      Request: https://quasar-cgfwjs-1.quasar-cgfwjs.root.hwx.site:31443/api/atlas/v2/entity/guid/eef4216f-0dc8-485d-9cc3-8ec96cfabf54

      Response:

      {
          "referredEntities": {},
          "entity": {
              "typeName": "kafka_topic",
              "attributes": {
                  "partitionCountLocal": 0,
                  "desiredRetentionInHrs": 0,
                  "retentionBytesNational": 0,
                  "contactInfo": null,
                  "replicatedFrom": null,
                  "displayName": null,
                  "numberOfEventsPerDay": 0,
                  "maxThroughputPerSec": 0,
                  "description": "topic_rhgua",
                  "retentiontimeLocalInHrs": 0,
                  "type": null,
                  "avroSchema": [],
                  "partitionCount": 1,
                  "owner": null,
                  "replicatedTo": null,
                  "userDescription": null,
                  "qualifiedName": "topic_rhgua@cm",
                  "segmentBytesNational": 0,
                  "partitionCountNational": 0,
                  "segmentBytesLocal": 0,
                  "uri": "topic_rhgua",
                  "replicationFactorNational": 0,
                  "avgMessageSizeInBytes": 0,
                  "replicationFactorLocal": 0,
                  "retentiontimeNationalInHrs": 0,
                  "retentionBytesLocal": 0,
                  "name": "topic_rhgua",
                  "topic": "topic_rhgua",
                  "keyClassname": null
              },
              "guid": "eef4216f-0dc8-485d-9cc3-8ec96cfabf54",
              "isIncomplete": false,
              "status": "ACTIVE",
              "createdBy": "kafka",
              "updatedBy": "kafka",
              "createTime": 1641491509705,
              "updateTime": 1641491509705,
              "version": 0,
              "relationshipAttributes": {
                  "inputToProcesses": [],
                  "pipeline": null,
                  "schema": [],
                  "kafkaConsumerLineage": null,
                  "model": null,
                  "kafkaProducerLineage": null,
                  "avroSchema": [],
                  "meanings": [],
                  "outputFromProcesses": []
              },
              "labels": []
          }
      }

      It has replicationFactorLocal and replicationFactorNational but does not contain replicationFactor

      It was working fine in the previous successful build:

      Attachments

        Activity

          People

            Unassigned Unassigned
            dharshmk Dharshana M Krishnamoorthy
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: