Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-4217

Add Environment Setup Page to Docs + Doc Bug

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: atlas-core
    • Labels:
      None

      Description

      The current build + installation docs don't outline that JDK8 is used for building/executing and that Python 2.7.7 is used for execution.  The latest (JDK15 and Python 3.x) don't work and give cryptic errors that inevitably generate more noise in the Jira issues. 

      These are notes on the Eclipse setup page but it's not specific to Eclipse. I needed these for building + running in a docker container with the embedded hbase + solr.

      Apache Atlas – Data Governance and Metadata framework for Hadoop

      ---------

       

      Also, the quick start script referenced in the page below should be bin/quick_start.py, not quick-start.sh as shown in the doc. 

      Apache Atlas – Data Governance and Metadata framework for Hadoop

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              scogro Scott Grosenick
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: