Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-4179

[Atlas: Glossary Term Bulk Import] Incorrect error message when only dependent term is not present in bulk import

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: atlas-core
    • Labels:
      None

      Description

      glossary_rb,term_1,"short description","long description", "Example", "G1", "Usage",,,,,,,,,,,,,,"gloss_1:term_2"

      Consider the above input, say gloss_1 is present but term term_2 is not present, error message conveys, that both glossary and term are not present

      Error message:

      {"errorCode":"ATLAS-500-00-001",
      "errorMessage":"The uploaded file has not been processed due to the following errors : \n[\nThe provided Reference Glossary and TermName does not exist in the system term_2:gloss_1 for record with TermName  : term_1 and GlossaryName : glossary_rb]"}

        Attachments

          Activity

            People

            • Assignee:
              chaitali chaitali borole
              Reporter:
              dharshmk Dharshana M Krishnamoorthy

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment