Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-2833

Associating tag to entity in UI throws exception since mapGraphToTypedInstance uses outdated transient typeSystem information

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.1-incubating
    • Fix Version/s: 0.7.1-incubating
    • Component/s: atlas-core
    • Labels:
      None

      Description

      While associating tag to the entity API throws exception but tag gets associated to the entity and then after entity fetch is not working unless you go to search table and remove the associated tag.

      Steps to reproduce.

      1. Create a new tag or run a quick-start
      2. After quick-start or creating tag restart the atlas
      3. Now go tags tab and add new attribute to the any tag
      4. Now associate the same tag to the entity it will show the error.

      Note: After restart if new attributes are created then that tag will not work it shows exception but if you create new tag after restart then it will work perfectly.

        Attachments

          Activity

            People

            • Assignee:
              sarath Sarath Subramanian
              Reporter:
              sarath Sarath Subramanian

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment