Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-2673

DSL query fired on PASSIVE server redirects to ACTIVE server with wrong encoding

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-alpha
    • Fix Version/s: 1.0.0
    • Component/s: atlas-webui
    • Labels:
      None

      Description

      DSL query :

      /api/atlas/v2/search/dsl?typeName=hive_table&query=name="weather2"
      

      fired on PASSIVE server redirects to ACTIVE server as

      /api/atlas/v2/search/dsl?limit=25&offset=0&query=name=%2522weather2%2522&typeName=hive_table
      

      fails with

      {
      errorCode: "ATLAS-400-00-059",
      errorMessage: "Invalid DSL query: `hive_table` name=%22weather2%22 | Reason: DSL Semantic Error - weather2 type not found, DSL Semantic Error - weather2 type not found, DSL Semantic Error - 22 type not found, DSL Semantic Error - 22 type not found. Please refer to Atlas DSL grammar for more information"
      }
      

      Attaching the complete exception stack trace from ACTIVE server logs .

      Issue not seen with Basic search.

        Attachments

        1. ATLAS-2673.patch
          4 kB
          Nixon Rodrigues

          Activity

            People

            • Assignee:
              nixonrodrigues Nixon Rodrigues
              Reporter:
              nixonrodrigues Nixon Rodrigues
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: