Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8-incubating, 0.9-incubating, 0.8.1-incubating
    • Component/s: None
    • Labels:
      None

      Description

      If the contains clause attribute value contains any of the special regex chars like

      "+", "|", "(", "{", "[", "*", "?", "$", "/", "^"

      then the graph query fails with Invalid pattern exception

      Solution: Escape all occurrences of the special characters

        Issue Links

          Activity

          grahamwallis Graham Wallis added a comment -

          Do you also need the right-hand versions of the various bracket/parenthesis characters? (i.e. ')', '}' and ']')

          apoorvnaik Apoorv Naik added a comment - Reporter

          Surprisingly the right hand counterparts were working fine with the index, I think the regex sees the left hand versions and then starts expecting a right hand one for the the same and errors out.

          I'll run some more tests to make sure that it works as intended.

          apoorvnaik Apoorv Naik added a comment - Reporter

          This should be extended for suffix regex matches too. And LIKE operator should match the provided value as is (user will most likely enter a regex for LIKE)

          apoorvnaik Apoorv Naik added a comment - Reporter

          Committed

          master : a785e935dc77234f783013f51ff23d8c9f0eca59
          0.8 : adaa9c439df69d8dafa85f1e1cb57aee4769f0b4


            People

            • Assignee:
              apoorvnaik Apoorv Naik
              Reporter:
              apoorvnaik Apoorv Naik
              Request participants:
              None
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: