Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-9237

[R] 0.17 install on Arch Linux



    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Information Provided
    • Affects Version/s: 0.17.1
    • Fix Version/s: 1.0.0
    • Component/s: R
    • Labels:
    • Environment:


      After reading the installation vignette I'm reporting this installation issue.

      I couldn't install the R package by building the C++ libraries as I hit:

      # arch arrow install unable to load shared object R/x86_64-pc-linux-gnu-library/4.0/00LOCK-arrow/00new/arrow/libs/arrow.so : undefined symbol: _ZTIN6apache6thrift8protocol9TProtocolE

      I tried to set R_LD_LIBRARY_PATH as suggested but it didn't help. Maybe I made a mistake.

      Using a prebuild arrow binary was failing as the version on the Arch AUR was 0.17.0 while the CRAN was wanting 0.17.1, and the even the AUR 0.17.0 install was failing because there are apparently issues with grpc 1.28+ (I was on 1.29.1) according to https://aur.archlinux.org/packages/arrow/

      I finally solved the issue by setting -DARROW_FLIGHT to OFF during installation from the AUR ( I also turned -DARROW_WITH_SNAPPY to ON):

      yay --editmenu -S arrow

      Then to install the R package I had to set NOT_CRAN=true & install the 0.17.0 version:

      packageurl <- "http://cran.r-project.org/src/contrib/Archive/arrow/arrow_0.17.0.tar.gz"
      install.packages(packageurl, repos=NULL, type="source")

      This led to a working R install, but I never solved my issue compiling the C++ binaries during R install. Perhaps this relates to the same issue with grpc?

      I'm sorry I didn't save all the error messages I hit, but I've included a working PKGBUILD for my system, edited from https://aur.archlinux.org/packages/arrow/. I hope it helps.


        1. PKGBUILD
          3 kB
          Stuart Russell



            • Assignee:
              npr Neal Richardson
              stuartrussell Stuart Russell
            • Votes:
              0 Vote for this issue
              2 Start watching this issue


              • Created: