Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-8577

[Plasma] PlasmaClient::Connect() of CUDA enabled build is always failed on no CUDA device machine

    XMLWordPrintableJSON

    Details

      Description

      We provide CUDA enabled Plasma packages for Debian GNU/Linux and Ubuntu.
      It must work on no CUDA device machine.

      The original report:

      Hi all,

       Previously, I was using c_glib Plasma library (build 0.12) for creating plasma objects. It was working as expected. But now I want to use Arrow's newest build.  I incurred the following error:

       
      /build/apache-arrow-0.17.0/cpp/src/arrow/result.cc:28: ValueOrDie called on an error: IOError: Cuda error 100 in function 'cuInit': [CUDA_ERROR_NO_DEVICE] no CUDA-capable device is detected
      I think plasma client options (gplasma_client_options_new()) which I am using with default settings are enabling a check for my CUDA device and I have no CUDA device attached to my system. How I can disable this check? Any help will be highly appreciated. Thanks

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kou Kouhei Sutou
                Reporter:
                tahmad Tanveer
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 2h 50m
                  2h 50m