Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-4764

[C++/Java] conda-built libplasma_java doesn't work with system Java on Ubuntu Xenial

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: C++, C++ - Plasma, Packaging, Python
    • Labels:
      None

      Description

      System Java will load also the system libstdc++ which is older then the conda provided one. Thus a later loading of the plasma library will raise missing symbol errors:

      Start process 317574433 OK, cmd = [/home/travis/build/xhochy/arrow/cpp-install/bin/plasma_store_server  -s  /tmp/store14796  -m  10000000]
      Start object store success
      Kill plasma store process forcely
      Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/travis/build/xhochy/arrow/cpp-build/debug/libplasma_java.so: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by /home/travis/build/xhochy/arrow/cpp-build/debug/libplasma.so.13)
      	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
      	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857)
      	at java.lang.Runtime.loadLibrary0(Runtime.java:870)
      	at java.lang.System.loadLibrary(System.java:1122)
      	at org.apache.arrow.plasma.PlasmaClientTest.<init>(PlasmaClientTest.java:49)
      	at org.apache.arrow.plasma.PlasmaClientTest.main(PlasmaClientTest.java:252)

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              uwe Uwe Korn
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: