Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.11.0
    • Fix Version/s: 0.10.0
    • Component/s: Java

      Description

      I'm trying to use the parquet-arrow module from parquet-mr but I'm running into this error because the two projects use different major versions of Java:

        Cause: java.lang.ClassNotFoundException: org.apache.arrow.vector.types.pojo.ArrowType$Struct_

      The struct is actually named `Struct` not `Struct_`.

      This PR is to track work to upgrade to JDK 1.8

      I should note that this is after the recent commit in parquet to upgrade to use arrow-0.8.0.

       

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                andygrove Andy Grove
                Reporter:
                andygrove Andy Grove
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1h
                  1h