Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-2464

[Python] Use a python_version marker instead of a condition

    XMLWordPrintableJSON

    Details

      Description

      When installing pyarrow 0.9.0 pipenv complains that futures has no matching versions.

      While that may be a bug in pipenv it does not matter. The standard way to specify a conditional dependency is using a marker.

      We should use the python_version marker to tell pip if it should install futures or not.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                the_drow Omer Katz
                Reporter:
                the_drow Omer Katz
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: