Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-15330

Relaxing `grpc-cpp` requirements to avoid package inconsistency

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Invalid
    • 6.0.1, 7.0.0
    • None
    • C++, Python
    • None
    • ubuntu

    Description

      Starting arrow `6.0.1`, the `grpc-cpp` requirement was raised to `>=1.42.0,<1.43.0a0` which forces the GCC stack (`libstdcxx-ng`, `ibgcc-ng`) to pin to `>=11.2.0`.  

       

      Prior to this change, the GCC stack was pinned to `>=9.4.0`.

       

      Due to this change, many downstream libraries will have a conflict as many OSS libraries rely on if they rely on default GCC of LTS versions of OS's. Currently, Ubuntu 20.04 ships with gcc-9 and ubuntu 22.04 which will have gcc-11 as default is not out yet. The lastest `nvcc` 11.5 also doesn't fully support host compiler gcc 11.x for the same reason. Hence is it possible to relax arrow-cpp's `grpc-cpp` requirements so that it is also compatible with `libstdcxx-ng`/`ibgcc-ng`>=9.4.0 and release binaries for `6.0.1`?

      Attachments

        Activity

          People

            Unassigned Unassigned
            galipremsagar Prem Sagar Gali
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: