Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-1148

[C++] Raise minimum CMake version to 3.2

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.5.0
    • Component/s: C++
    • Labels:
      None

      Description

      This will help us eliminate a lot of cruft in the build system. It's relatively straightforward to get a newer CMake on older Linux distributions, so I don't think this is too onerous on users.

      Philipp Moritz do you anticipate this causing you any issues? On Ubuntu 14.04 you have to get CMake 3.2 from a PPA, the one in mainline is very old. In newer Linuxes I believe it's new enough. You can also obtain cmake from pip and conda

        Attachments

          Activity

            People

            • Assignee:
              wesmckinn Wes McKinney
              Reporter:
              wesmckinn Wes McKinney
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: