Uploaded image for project: 'Aries'
  1. Aries
  2. ARIES-849

Move to 1.0.0 versions to enable semantic versioning

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Reopened
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      We have now reached the point where using 0.x versions are seriously affecting our ability to describe how our bundles depend on one another, and our ability to do releases.

      See http://aries.15396.n3.nabble.com/Aries-releases-oh-the-misery-td3798391.html for further discussion.

      Tasks are:

      • Update poms to declare 1.0.0 versions
      • Change all dependencies to 1.0.0-SNAPSHOT, to be switched to minimum released versions once we have have a 1.0.0 release
      • Change all exported packages to 1.0,0 versions
      • Remove all artificial restrictions on imported version ranges, so we get [1.0, 2.0) ranges by default
      • Identify package implementors and declare them, so we get [1.0, 1.1) ranges for providers

        Attachments

          Activity

            People

            • Assignee:
              cumminsh@uk.ibm.com Holly Cummins
              Reporter:
              cumminsh@uk.ibm.com Holly Cummins
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: