Uploaded image for project: 'Aries'
  1. Aries
  2. ARIES-1935

Aries JAXRS whiteboard features xml deployed incorrectly (or at least confusingly).

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: jax-rs-whiteboard-1.0.6
    • Fix Version/s: None
    • Component/s: jax-rs-whiteboard
    • Labels:
      None

      Description

      I wanted to try out the aries jaxrs whiteboard and so I added the features,xml to my pom so it would get added to my project features.xml like this:

      <dependency>
      <groupId>org.apache.aries.jax.rs</groupId>
      <artifactId>org.apache.aries.jax.rs.features</artifactId>
      <version>1.0.6</version>
      <classifier>features</classifier>
      <type>xml</type>
      </dependency>

      But maven couldn't find it.  I also tried loading it via karaf using: mvn:org.apache.aries.jax.rs/org.apache.aries.jax.rs.features/1.0.6/xml/features but that won't resolve either despite it being in central here: https://repo1.maven.org/maven2/org/apache/aries/jax/rs/org.apache.aries.jax.rs.features/1.0.6/

      I looked at the Karaf examples and noticed that the features xml is being deployed without the features classifier on it, which is very confusing.  Will this be corrected or is it going to stay like that since that's how it ended up being deployed?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rmoquin Ryan Moquin
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: