Uploaded image for project: 'Aries'
  1. Aries
  2. ARIES-1156

SPI-Fly static tool does not work with Require-Capability bundles

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: subsystem-1.0.1
    • Component/s: None
    • Labels:
      None

      Description

      When processing the spi-fly-example-client2-bundle with the static tool, the bundle contains invalid metadata and will not install.

      Installation of the org.apache.aries.spifly.examples.client2.bundle-1.0.1-SNAPSHOT_spifly.jar bundle in Equinox yields the following exception:

      Invalid manifest header Require-Capability: "osgi.serviceloader; filter:="(osgi.serviceloader=org.apache.aries.spifly.mysvc.SPIProvider)";cardinality:=multiple,"

      Note the trailing comma that should not be there.

        Attachments

          Activity

            People

            • Assignee:
              bosschaert David Bosschaert
              Reporter:
              bosschaert David Bosschaert
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: