Uploaded image for project: 'Maven Archetype'
  1. Maven Archetype
  2. ARCHETYPE-81

Archetype not downloaded until pom is placed in working dir

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0-alpha-4
    • Fix Version/s: None
    • Component/s: Plugin
    • Labels:
      None

      Description

      Our archetype is hosted internally in the company repository.
      Our settings.xml contains profiles with the internal repository locations.

      I mkdir C:\temp\archtest
      I execute mvn archetype:create -D.... etc
      I get "could not download archetype ... from central

      Next I put a valid pom.xml in the working dir
      I execute mvn archetype:create -D etc
      I get an expected error since the directory is not empty, but now if I check my local repository the archetype is downloaded from the company repository. !! Why wasn't it found until a pom.xml is in the directory?
      Now I delete the pom.xml
      Now I can build sucessfully.

      It would appear the profiles where we define our repositories are not being used until the pom.xml is available. But even mvn -P archetype:create doesn't resolve the issue.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              treilly Tim Reilly
            • Votes:
              4 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: