Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: Generator
    • Labels:
      None
    • Environment:
      n/a

      Description

      The archetypeRepository param makes it possible to bypass the configured Maven repos for retrieving an archetype. This is not good.

        Issue Links

          Activity

          hsaputra Henry Saputra added a comment - - edited

          The description of this bug is also bit vague.
          Why is it not good? What is the proposed solution? Why would proposed solution work?

          See ARCHETYPE-519 for after math of these changes.

          I understand major version changes can be used for "breaking" changes but it should have good reason why and have users to have equivalent solution or path to achieve similar result.
          Thanks.

          khmarbaise Karl Heinz Marbaise added a comment -

          Kent Chen First can you please more specific what exactly the problem is (and yes breaking is done with a major version change) and furthermore don't use JIRA issues for discussion please come onto the dev mailing list for further discussion...

          chenjianjx Kent Chen added a comment -

          Who did this?! Don't you know that backward compatibility is very important ? Oh my god, my open source generator project has been broken.

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build maven-archetype-m3 #255 (See https://builds.apache.org/job/maven-archetype-m3/255/)
          ARCHETYPE-439 Remove archetypeRepository param (rfscholte: rev 3670dff7b762caa5517e172e4ae08ee088b6eb5f)

          • (edit) maven-archetype-plugin/src/main/java/org/apache/maven/archetype/mojos/CreateProjectFromArchetypeMojo.java
          • (edit) archetype-models/archetype-catalog/src/main/mdo/archetype-catalog.mdo
          • (edit) archetype-common/src/main/java/org/apache/maven/archetype/ArchetypeGenerationRequest.java
          • (edit) maven-archetype-plugin/src/main/java/org/apache/maven/archetype/ui/generation/DefaultArchetypeSelector.java

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              afloom Anders Hammar
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development