Maven Archetype
  1. Maven Archetype
  2. ARCHETYPE-222

archetype:generate don't use <localRepository> in settings.xml when looking for archetype-catalog.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0-alpha-4
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP, Maven 2.0.9, archetype 2.0-alpha4

      Description

      mvn archetype:generate always looks for ~/.m2/archetype-catalog.xml.

      I've overriden local repository location in my settings.xml :
      <localRepository>D:\Documents\Developpements\.m2\repository</localRepository>

      I would have expected archetype:generate to look after D:\Documents\Developpements\.m2\repository\archetype-catalog.xml, but this is not the case.

        Activity

        gonzalad created issue -
        gonzalad added a comment -

        Temporary workaround :
        . I create archetype-catalog.xml using mvn archetype:crawl.
        . Deploy archetype-catalog.xml on http server (http://myserver/archetypes).
        . Launch 'mvn archetype:generate -DarchetypeCatalog=http://myserver/archetypes'

        Raphaël Luta added a comment -

        Duplicate of ARCHETYPE-142

        Raphaël Luta made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Duplicate [ 3 ]
        Martin Gainty added a comment -

        confirmed any/all attempts to use localRepository in 2.0.9 failse.g.
        mvn -DlocalRepository=ValidPathForPlugin install
        FAILS to use localRepository

        %M2_HOME%/conf/settings.xml
        <settings>
        <localRepository>F:\Maven-plugin</localRepository>
        FAILS

        I'll check 2.10
        MCG 01/04/09

        Mark Thomas made changes -
        Project Import Sun Apr 05 09:05:55 UTC 2015 [ 1428224755734 ]
        Mark Thomas made changes -
        Workflow jira [ 12716681 ] Default workflow, editable Closed status [ 12748161 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 22:17:37 UTC 2015 [ 1428272257260 ]
        Mark Thomas made changes -
        Workflow jira [ 12953877 ] Default workflow, editable Closed status [ 12990972 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        6d 4h 5m 1 Raphaël Luta 03/Dec/08 13:47

          People

          • Assignee:
            Unassigned
            Reporter:
            gonzalad
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development