Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not A Problem
    • Affects Version/s: 2.0-alpha-3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Maven version: 2.0.8
      Java version: 1.5.0_11
      OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"

      Description

      mvn archetype:help should not require a pom.

      This goal only runs successfully if issued from a directory which contains a valid pom.

      This is counter-intuitive, as mvn archetype:generate does not have this requirement.

        Issue Links

          Activity

          Neil Crow created issue -
          Benjamin Bentmann made changes -
          Field Original Value New Value
          Link This issue depends upon MPLUGIN-92 [ MPLUGIN-92 ]
          Nick Stolwijk added a comment -

          Just tested it with the trunk version and there it works. It has been fixed by updating the maven-plugin-plugin version to 2.4.3 in r703584.

          Raphaël Luta added a comment -

          Already closed

          Raphaël Luta made changes -
          Resolution Not A Bug [ 6 ]
          Fix Version/s 2.0-alpha-5 [ 14254 ]
          Status Open [ 1 ] Closed [ 6 ]
          Michael Osipov made changes -
          Fix Version/s 2.0-alpha-5 [ 14254 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 09:05:55 UTC 2015 [ 1428224755734 ]
          Mark Thomas made changes -
          Link This issue depends upon MPLUGIN-92 [ MPLUGIN-92 ]
          Mark Thomas made changes -
          Workflow jira [ 12716676 ] Default workflow, editable Closed status [ 12748061 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 22:17:37 UTC 2015 [ 1428272257260 ]
          Mark Thomas made changes -
          Link This issue depends upon MPLUGIN-92 [ MPLUGIN-92 ]
          Mark Thomas made changes -
          Workflow jira [ 12954240 ] Default workflow, editable Closed status [ 12991560 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          172d 6h 48m 1 Raphaël Luta 11/Apr/09 17:45

            People

            • Assignee:
              Unassigned
              Reporter:
              Neil Crow
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development