Uploaded image for project: 'ActiveMQ .Net'
  1. ActiveMQ .Net
  2. AMQNET-565

Dotnet core port

    XMLWordPrintableJSON

Details

    Description

      Apache.NMS.ActiveMQ should be ported for dotnet core.

      For now the following error is rises:
      D:\RiderProjects\syncro [master ≡ +1 ~1 -1 !]> dotnet add package Apache.NMS.ActiveMQ
      Microsoft (R) Build Engine version 15.1.1012.6693
      Copyright (C) Microsoft Corporation. All rights reserved.

      Writing C:\Users\wkulma\AppData\Local\Temp\tmp9A2E.tmp
      info : Adding PackageReference for package 'Apache.NMS.ActiveMQ' into project 'D:\RiderProjects\syncro\syncro.fsproj'.
      log : Restoring packages for D:\RiderProjects\syncro\syncro.fsproj...
      info : GET https://api.nuget.org/v3-flatcontainer/apache.nms.activemq/index.json
      info : CACHE https://api.nuget.org/v3-flatcontainer/fsharp.core/index.json
      info : CACHE https://api.nuget.org/v3-flatcontainer/fsharp.core/4.1.17/fsharp.core.4.1.17.nupkg
      info : CACHE https://api.nuget.org/v3-flatcontainer/fsharp.net.sdk/index.json
      info : CACHE https://api.nuget.org/v3-flatcontainer/fsharp.net.sdk/1.0.5/fsharp.net.sdk.1.0.5.nupkg
      info : OK https://api.nuget.org/v3-flatcontainer/apache.nms.activemq/index.json 611ms
      info : GET https://api.nuget.org/v3-flatcontainer/apache.nms.activemq/1.7.2/apache.nms.activemq.1.7.2.nupkg
      info : OK https://api.nuget.org/v3-flatcontainer/apache.nms.activemq/1.7.2/apache.nms.activemq.1.7.2.nupkg 481ms
      error: Package Apache.NMS.ActiveMQ 1.7.2 is not compatible with netcoreapp1.1 (.NETCoreApp,Version=v1.1). Package Apache.NMS.ActiveMQ 1.7.2 supports:
      error: - net20 (.NETFramework,Version=v2.0)
      error: - net35 (.NETFramework,Version=v3.5)
      error: - net40 (.NETFramework,Version=v4.0)
      error: Package Apache.NMS 1.7.1 is not compatible with netcoreapp1.1 (.NETCoreApp,Version=v1.1). Package Apache.NMS 1.7.1 supports:
      error: - net20 (.NETFramework,Version=v2.0)
      error: - net20-cf (.NETFramework,Version=v2.0,Profile=CompactFramework)
      error: - net35 (.NETFramework,Version=v3.5)
      error: - net40 (.NETFramework,Version=v4.0)
      error: One or more packages are incompatible with .NETCoreApp,Version=v1.1.
      error: Package 'Apache.NMS.ActiveMQ' is incompatible with 'all' frameworks in project 'D:\RiderProjects\syncro\syncro.fsproj'.

      Attachments

        Activity

          People

            Unassigned Unassigned
            wojtekkulma Wojtek Kulma
            Votes:
            3 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 14h 50m
                14h 50m