ActiveMQ .Net
  1. ActiveMQ .Net
  2. AMQNET-376

Documentation: property for asynchronous sending incorrect in website tutorial documentation

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5.3
    • Fix Version/s: None
    • Component/s: ActiveMQ

      Description

      In this page
      http://activemq.apache.org/nms/activemq-async-sends.html

      there are 4 defects in the documentation:

      1.
      var cf = new ConnectionFactory("tcp://locahost:61616?nms.useAsyncSend=true");
      should read
      var cf = new ConnectionFactory("tcp://locahost:61616?nms.AsyncSend=true");

      2.
      ((ConnectionFactory)connectionFactory).UseAsyncSend = true;
      should read
      ((ConnectionFactory)connectionFactory).AsyncSend = true;

      3.
      ((Apache.NMS.ActiveMQ.Connection)connection).UseAsyncSend = true;
      should read:
      ((Apache.NMS.ActiveMQ.Connection)connection).AsyncSend = true;

      4.
      there is a link labelled "Should I use transactions"
      which takes you this 404: http://activemq.apache.org/ACTIVEMQ/should-i-use-transactions.html
      the link should take you here: http://activemq.apache.org/should-i-use-transactions.html
      Compare with: http://activemq.apache.org/async-sends.html

      Other documentation that might have defects like 1,2,3:
      On http://activemq.apache.org/nms/activemq-uri-configuration.html
      connection.AsyncSend is correctly listed, (no nms.* settings are shown).

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Timothy Bish
            Reporter:
            Andrew Liles
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development