Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-646

Receiver hangs after receiving about 1000 messages

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0 M4
    • Fix Version/s: 4.0 RC2
    • Component/s: None
    • Labels:
      None
    • Environment:

      linux

    • Regression:
      Regression

      Description

      I'm using ActiveMQ whith Jencks JCA container. After receiving about 1000 messages, my listener stops receiving any messages. If I restart client application, again about 1000 messages are received. It only happens inside Jencks container. If I'm using my own listener, everything works fine. Everything was working fine on ActiveMQ 3.2

        Issue Links

          Activity

          jurna Danielius Jurna added a comment -

          It seems that this issue occures only when thread pool size in Jencks container is more than 2. If there's only 2 threads in the pool, all messages are consumed.

          jurna Danielius Jurna added a comment -

          It seems that the cause of this issue is AMQ-587


            People

            • Assignee:
              Unassigned
              Reporter:
              jurna Danielius Jurna
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development