Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6452

Geronimo transaction manager dependency version should be upgraded

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.14.1
    • Fix Version/s: 5.15.0
    • Component/s: Pool
    • Labels:
      None

      Description

      Actually version of gtm is 2.2.1.

      <dependency>
          <groupId>org.apache.geronimo.components</groupId>
          <artifactId>geronimo-transaction</artifactId>
          <version>2.2.1</version>
      </dependency>
      

      Karaf for example does install gtm > 3.x.x since years and does therefor not support recovery together with activemq-jms-pool implementation. (NoClassDefFoundError!)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                graben Benjamin Graf
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: