Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6416

leveldbjni requires additional jars

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 5.14.0
    • Fix Version/s: None
    • Component/s: Message Store
    • Labels:

      Description

      When configuring activemq to use native jni leveldb adaptor, it fails to start due to missing leveldbjni-linux32-1.8.jar or leveldbjni-linux64-1.8.jar.

      The leveldbjni-1.8.jar is included, in lib/optional, but it also requires one of the two above jars (depending on your platform.

      Should activemq be packaging these along with leveldbjni-1.8.jar ?

      The errors logged when they are missing aren't particularly helpful!

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              johnleach John Leach
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: