Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6218

Message content returns null occasionally from Virtual Topic to the consumer

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.12.2, 5.13.2
    • Fix Version/s: 5.13.3, 5.14.0
    • Component/s: None
    • Labels:
      None

      Description

      I have 1 Virtual Topic and 40 Consumer to consume the messages sent by the topic. The problem is when I am sending thousands of Messages lets say 10000 via Virtual Topic I have noticed that 2 or 3 consumer are getting null as a text when I do message.getText(), but virtual topic is not sending a null as a text message if it so then all 40 consumer should report same.

      I have also noticed this problem is not happening in AMQ v5.11 or with levelDB in AMQ v5.12.2/5.13.2. It is happening only in when you use kahaDB with AMQ v5.12.2/5.13.2

        Attachments

        1. App.java
          5 kB
          Rohit Sonawat
        2. Full app.log
          9.13 MB
          Rohit Sonawat
        3. AMQ6218Test.java
          8 kB
          Timothy Bish

          Issue Links

            Activity

              People

              • Assignee:
                cshannon Christopher L. Shannon
                Reporter:
                rohitsonawat@gmail.com Rohit Sonawat
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: