Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-4735

LinkageError in latest 5.9 snapshot

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: 5.9.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      activemq-5.9-20130919.101342-100

      Description

      When upgrading a test broker to the latest 5.9 snapshot I get:

      java.lang.LinkageError: loader constraint violation: when resolving method "org.slf4j.impl.StaticLoggerBinder.getLoggerFactory()Lorg/slf4j/ILoggerFactory;" the class loader (instance of org/eclipse/jetty/webapp/WebAppClassLoader) of the current class, org/slf4j/LoggerFactory, and the class loader (instance of java/net/URLClassLoader) for resolved class, org/slf4j/impl/StaticLoggerBinder, have different Class objects for the type org/slf4j/ILoggerFactory used in the signature

        Attachments

        1. activemq.log
          11 kB
          Lionel Cons

          Activity

            People

            • Assignee:
              davsclaus Claus Ibsen
              Reporter:
              lionel.cons Lionel Cons
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: