Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-4537

activemq-perftest broken in 5.8.0

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.8.0
    • Fix Version/s: 5.9.0
    • Component/s: Performance Test
    • Labels:
      None
    • Environment:

      Ubuntu 12.10
      Maven 3.0.4

      Description

      I tried setting up my own Maven project to do some ActiveMQ load tests and also used the code at http://svn.apache.org/repos/asf/activemq/sandbox/activemq-perftest/. Both give me the same error below when I execute: mvn activemq-perf:broker -Durl=broker:tcp://localhost:61616

      The double-var-encoded string looks strange. I also end up with a folder in the project directory: ${${project.build.directory}}.

      I am able to run other Maven plugins in the project and other local projects just fine.

      java.net.URISyntaxException: Illegal character in path at index 1: ${${url}}
      at java.net.URI$Parser.fail(URI.java:2829)
      at java.net.URI$Parser.checkChars(URI.java:3002)
      at java.net.URI$Parser.parseHierarchical(URI.java:3086)
      at java.net.URI$Parser.parse(URI.java:3044)
      at java.net.URI.<init>(URI.java:595)
      at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:95)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:150)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:104)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at org.apache.activemq.console.Main.runTaskClass(Main.java:262)
      at org.apache.activemq.console.Main.main(Main.java:115)
      at org.apache.activemq.maven.ServerMojo.execute(ServerMojo.java:108)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)

      After running mvn --debug, I can also see this being generated:

      [DEBUG] Configuration: <?xml version="1.0" encoding="UTF-8"?>
      <configuration>
      <configDirectory default-value="${basedir}/src/main/resources/broker-conf">${${configDirectory}}</configDirectory>
      <configFile>${${configFile}}</configFile>
      <configType default-value="activemq">${${configType}}</configType>
      <outputDirectory>${${project.build.directory}}</outputDirectory>
      <url>${${url}}</url>
      </configuration>

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ceposta Christian Posta
                Reporter:
                nickspacek Nick Spacek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: