Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-3825

Exceptions in broker logs :- Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long:

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 5.5.1
    • Fix Version/s: None
    • Component/s: Broker, Connector
    • Labels:
      None

      Description

      Hi,
      I am seeing lot of InactivityIO exceptions in my broker logs:-

      activemq.log.2012-03-01:2012-03-01 18:56:49,519 | INFO | Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: /10.240.170.27:42813 | org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@8fe952[State = 0, empty queue]
      activemq.log.2012-03-01:2012-03-01 19:06:52,464 | INFO | Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: /10.253.127.196:62265 | org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@1501b4f[State = 0, empty queue]
      activemq.log.2012-03-01:2012-03-01 19:27:37,074 | INFO | Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: /149.77.160.18:52472 | org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@19e0323[State = 0, empty queue]
      activemq.log.2012-03-01:2012-03-01 23:33:51,632 | INFO | Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: /149.77.160.18:33558 | org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@168a9ba[State = 0, empty queue]
      activemq.log.2012-03-01:2012-03-01 23:33:56,975 | INFO | Transport failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>30000) long: /149.77.160.18:55158 | org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@116f46b[State = 0, empty queue]

      I am trying to reproduce this with the pooled connection factory but this is not consistently reproducible. Can somebody throw light on the exact cause of this. I don't want to use the inactivityMonitor property.

      Thanks,
      Bhanu

        Attachments

        1. activemq.xml
          2 kB
          Boovaraghavan

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              xbhanu Bhanu
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: