ActiveMQ
  1. ActiveMQ
  2. AMQ-3427

Activemq-trunk does not compile with JDK7

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 5.5.0
    • Fix Version/s: 5.6.0
    • Component/s: Broker
    • Labels:
      None
    • Environment:

      Description

      This is due to the maven-war-plugin, patch forthcoming.

      [INFO] Packaging webapp
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      ---- Debugging information ----
      message : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
      cause-message : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      class : org.apache.maven.plugin.war.util.WebappStructure
      required-type : org.apache.maven.plugin.war.util.WebappStructure
      path : /webapp-structure
      line number : 1
      -------------------------------
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      com.thoughtworks.xstream.converters.ConversionException: Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      ---- Debugging information ----
      message : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
      cause-message : Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      class : org.apache.maven.plugin.war.util.WebappStructure
      required-type : org.apache.maven.plugin.war.util.WebappStructure
      path : /webapp-structure
      line number : 1
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshall
      er.java:89)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(A
      bstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:923)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:909)
      at com.thoughtworks.xstream.XStream.fromXML(XStream.java:853)
      at org.apache.maven.plugin.war.util.WebappStructureSerializer.fromXml(WebappStructureSerializer.java:73)
      at org.apache.maven.plugin.war.AbstractWarMojo.buildWebapp(AbstractWarMojo.java:423)
      at org.apache.maven.plugin.war.AbstractWarMojo.buildExplodedWebapp(AbstractWarMojo.java:394)
      at org.apache.maven.plugin.war.WarMojo.performPackaging(WarMojo.java:195)
      at org.apache.maven.plugin.war.WarMojo.execute(WarMojo.java:157)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: com.thoughtworks.xstream.converters.reflection.ObjectAccessException: Cannot construct org.apache.maven.plugin.war.util.WebappStructure as it does not have a no-args constructor
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.newInstance(PureJavaReflectionProvider.java:71)
      at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.instantiateNewInstance(AbstractReflectionConverter.java:308)
      at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshal(AbstractReflectionConverter.java:161)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      ... 32 more

      1. fix_compiler.patch
        0.6 kB
        Allen Reese
      2. AMQ-3427-archiver.patch
        1 kB
        Allen Reese
      3. AMQ-3427.patch
        1.0 kB
        Allen Reese
      4. AMQ_3427-2.patch
        2 kB
        Allen Reese

        Activity

        Allen Reese added a comment -

        Patch to fix the maven-war-plugin version to be 2.1.1 which works with JDK.7

        Dejan Bosanac added a comment -

        Patch applied with svn revision 1152720. Thanks!

        Allen Reese added a comment -

        I thought it was just the site plugin, but it looks like the jdk generics tightening have made things a little rough.

        Error log forth coming, I'll take a hack at another patch as I also see these errors in 5.3.2 building under jdk7.

        Allen Reese added a comment -

        Path: .
        URL: http://svn.apache.org/repos/asf/activemq/trunk
        Repository Root: http://svn.apache.org/repos/asf
        Repository UUID: 13f79535-47bb-0310-9956-ffa450edef68
        Revision: 1152856
        Node Kind: directory
        Schedule: normal
        Last Changed Author: dejanb
        Last Changed Rev: 1152757
        Last Changed Date: 2011-08-01 06:14:55 -0700 (Mon, 01 Aug 2011)

        /home/y/libexec/maven/bin/mvn verify
        [INFO] Scanning for projects...
        [INFO] Reactor build order:
        [INFO] ActiveMQ
        [INFO] ActiveMQ :: KahaDB
        [INFO] ActiveMQ :: JAAS
        [INFO] Openwire Generator
        [INFO] ActiveMQ :: jmdns 1.0
        [INFO] ActiveMQ :: Core
        [INFO] ActiveMQ :: RA
        [INFO] ActiveMQ :: Pool
        [INFO] ActiveMQ :: Spring
        [INFO] ActiveMQ :: Camel
        [INFO] ActiveMQ :: Console
        [INFO] ActiveMQ :: Optional
        [INFO] ActiveMQ :: Jar Bundle
        [INFO] ActiveMQ :: File Server
        [INFO] ActiveMQ :: Blueprint
        [INFO] ActiveMQ :: Apache Karaf
        [INFO] ActiveMQ :: RAR
        [INFO] ActiveMQ :: Run Jar
        [INFO] ActiveMQ Tooling
        [INFO] ActiveMQ :: Memory Usage Test Plugin
        [INFO] ActiveMQ :: Performance Test Plugin
        [INFO] ActiveMQ :: StartUp Plugin
        [INFO] ActiveMQ :: Web
        [INFO] ActiveMQ :: Web Demo
        [INFO] ActiveMQ :: XMPP
        [INFO] ActiveMQ :: Web Console
        [INFO] ActiveMQ :: Assembly
        [INFO] ------------------------------------------------------------------------
        [INFO] Building ActiveMQ
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
        [INFO] Setting property: velocimacro.messages.on => 'false'.
        [INFO] Setting property: resource.loader => 'classpath'.
        [INFO] Setting property: resource.manager.logwhenfound => 'false'.
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [site:attach-descriptor

        {execution: default-attach-descriptor}

        ]
        [INFO] [ianal:verify-legal-files

        {execution: default}

        ]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building ActiveMQ :: KahaDB
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [resources:resources

        {execution: default-resources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] Copying 2 resources
        [INFO] Copying 3 resources
        [INFO] [compiler:compile

        {execution: default-compile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [INFO] [resources:testResources

        {execution: default-testResources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] Copying 1 resource
        [INFO] Copying 3 resources
        [INFO] [compiler:testCompile

        {execution: default-testCompile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [WARNING] DEPRECATED [systemProperties]: Use systemPropertyVariables instead.
        [INFO] [surefire:test

        {execution: default-test}

        ]
        [INFO] Surefire report directory: /home/areese/dev/svn/activemq/activemq-trunk/kahadb/target/surefire-reports

        -------------------------------------------------------
        T E S T S
        -------------------------------------------------------
        Running org.apache.kahadb.index.ListIndexTest
        Tests run: 9, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 24.385 sec
        Running org.apache.kahadb.index.HashIndexTest
        Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 16.877 sec
        Running org.apache.kahadb.journal.JournalTest
        Tests run: 5, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.794 sec
        Running org.apache.kahadb.page.PageFileTest
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 2.063 sec
        Running org.apache.kahadb.index.BTreeIndexTest
        Tests run: 6, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 5.736 sec

        Results :

        Tests run: 24, Failures: 0, Errors: 0, Skipped: 0

        [INFO] [bundle:bundle

        {execution: default-bundle}

        ]
        Should not skip: ^
        Should not skip: ^
        Should not skip: ^
        [INFO] [ianal:verify-legal-files

        {execution: default}

        ]
        [INFO] Checking legal files in: kahadb-5.6-SNAPSHOT.jar
        [INFO] ------------------------------------------------------------------------
        [INFO] Building ActiveMQ :: JAAS
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [resources:resources

        {execution: default-resources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] skip non existing resourceDirectory /home/areese/dev/svn/activemq/activemq-trunk/activemq-jaas/src/main/resources
        [INFO] Copying 3 resources
        [INFO] [compiler:compile

        {execution: default-compile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [INFO] [resources:testResources

        {execution: default-testResources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] Copying 6 resources
        [INFO] Copying 3 resources
        [INFO] [compiler:testCompile

        {execution: default-testCompile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [WARNING] DEPRECATED [systemProperties]: Use systemPropertyVariables instead.
        [INFO] [surefire:test

        {execution: default-test}

        ]
        [INFO] Surefire report directory: /home/areese/dev/svn/activemq/activemq-trunk/activemq-jaas/target/surefire-reports

        -------------------------------------------------------
        T E S T S
        -------------------------------------------------------
        Running org.apache.activemq.jaas.GroupPrincipalTest
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.483 sec
        Running org.apache.activemq.jaas.CertificateLoginModuleTest
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.487 sec
        Running org.apache.activemq.jaas.PropertiesLoginModuleTest
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.021 sec
        Running org.apache.activemq.jaas.UserPrincipalTest
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.007 sec
        Running org.apache.activemq.jaas.GuestLoginModuleTest
        Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.006 sec
        Running org.apache.activemq.jaas.LDAPLoginModuleTest
        Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 8.239 sec

        Results :

        Tests run: 16, Failures: 0, Errors: 0, Skipped: 0

        [INFO] [bundle:bundle

        {execution: default-bundle}

        ]
        [INFO] [ianal:verify-legal-files

        {execution: default}

        ]
        [INFO] Checking legal files in: activemq-jaas-5.6-SNAPSHOT.jar
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Openwire Generator
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [resources:resources

        {execution: default-resources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] skip non existing resourceDirectory /home/areese/dev/svn/activemq/activemq-trunk/activemq-openwire-generator/src/main/resources
        [INFO] Copying 3 resources
        [INFO] [compiler:compile

        {execution: default-compile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [INFO] [resources:testResources

        {execution: default-testResources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] skip non existing resourceDirectory /home/areese/dev/svn/activemq/activemq-trunk/activemq-openwire-generator/src/test/resources
        [INFO] Copying 3 resources
        [INFO] [compiler:testCompile

        {execution: default-testCompile}

        ]
        [INFO] No sources to compile
        [INFO] [surefire:test

        {execution: default-test}

        ]
        [INFO] Tests are skipped.
        [INFO] [jar:jar

        {execution: default-jar}

        ]
        [INFO] Building jar: /home/areese/dev/svn/activemq/activemq-trunk/activemq-openwire-generator/target/activemq-openwire-generator-5.6-SNAPSHOT.jar
        [INFO] [ianal:verify-legal-files

        {execution: default}

        ]
        [INFO] Checking legal files in: activemq-openwire-generator-5.6-SNAPSHOT.jar
        [INFO] ------------------------------------------------------------------------
        [INFO] Building ActiveMQ :: jmdns 1.0
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [resources:resources

        {execution: default-resources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] Copying 1 resource
        [INFO] Copying 3 resources
        [INFO] [compiler:compile

        {execution: default-compile}

        ]
        [INFO] Nothing to compile - all classes are up to date
        [INFO] [resources:testResources

        {execution: default-testResources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] skip non existing resourceDirectory /home/areese/dev/svn/activemq/activemq-trunk/activemq-jmdns_1.0/src/test/resources
        [INFO] Copying 3 resources
        [INFO] [compiler:testCompile

        {execution: default-testCompile}

        ]
        [INFO] No sources to compile
        [INFO] [surefire:test

        {execution: default-test}

        ]
        [INFO] Tests are skipped.
        [INFO] [jar:jar

        {execution: default-jar}

        ]
        [INFO] Building jar: /home/areese/dev/svn/activemq/activemq-trunk/activemq-jmdns_1.0/target/activemq-jmdns_1.0-5.6-SNAPSHOT.jar
        [INFO] [ianal:verify-legal-files

        {execution: default}

        ]
        [INFO] Checking legal files in: activemq-jmdns_1.0-5.6-SNAPSHOT.jar
        [INFO] ------------------------------------------------------------------------
        [INFO] Building ActiveMQ :: Core
        [INFO] task-segment: [verify]
        [INFO] ------------------------------------------------------------------------
        [INFO] [enforcer:enforce

        {execution: default}

        ]
        [INFO] [bundle:cleanVersions

        {execution: cleanVersions}

        ]
        [WARNING] While downloading javacc:javacc:3.2
        This artifact has been relocated to net.java.dev.javacc:javacc:3.2.

        [INFO] [javacc:javacc

        {execution: default}

        ]
        [INFO] Nothing to process - all grammars are up to date
        [INFO] [activemq-protobuf:compile

        {execution: default}

        ]
        [INFO] Compiling: /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/proto/journal-data.proto
        [INFO] [remote-resources:process

        {execution: default}

        ]
        [INFO] [resources:resources

        {execution: default-resources}

        ]
        [INFO] Using 'UTF-8' encoding to copy filtered resources.
        [INFO] Copying 56 resources
        [INFO] Copying 3 resources
        [INFO] [compiler:compile

        {execution: default-compile}

        ]
        [INFO] Compiling 1405 source files to /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/target/classes
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] Compilation failure

        could not parse error message: warning: [options] bootstrap class path not set in conjunction with -source 1.6
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/usage/Usage.java:60: error: name has private access in Usage
        name = parent.name + ":" + name;
        ^

        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/usage/Usage.java:[297,22] error: addChild(T) has private access in Usage

        could not parse error message: where T is a type-variable:
        T extends Usage declared in class Usage
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/usage/Usage.java:309: error: removeChild(T) has private access in Usage
        parent.removeChild(this);
        ^

        could not parse error message: where T is a type-variable:
        T extends Usage declared in class Usage
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/kaha/MapContainer.java:85: error: name clash: containsKey(K) in MapContainer and containsKey(Object) in Map have the same erasure, yet neither overrides the other
        boolean containsKey(K key);
        ^

        could not parse error message: where K is a type-variable:
        K extends Object declared in interface MapContainer
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/kaha/MapContainer.java:93: error: name clash: get(K) in MapContainer and get(Object) in Map have the same erasure, yet neither overrides the other
        V get(K key);
        ^

        could not parse error message: where K,V#1,V#2 are type-variables:
        K extends Object declared in interface MapContainer
        V#1 extends Object declared in interface MapContainer
        V#2 extends Object declared in interface Map
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/kaha/MapContainer.java:99: error: name clash: containsValue(K) in MapContainer and containsValue(Object) in Map have the same erasure, yet neither overrides the other
        boolean containsValue(K o);
        ^

        could not parse error message: where K is a type-variable:
        K extends Object declared in interface MapContainer
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/kaha/MapContainer.java:106: error: name clash: putAll(Map<K#1,V#1>) in MapContainer and putAll(Map<? extends K#2,? extends V#2>) in Map have the same erasure, yet neither overrides the other
        void putAll(Map<K, V> map);
        ^

        could not parse error message: where K#1,V#1,K#2,V#2 are type-variables:
        K#1 extends Object declared in interface MapContainer
        V#1 extends Object declared in interface MapContainer
        K#2 extends Object declared in interface Map
        V#2 extends Object declared in interface Map
        /home/areese/dev/svn/activemq/activemq-trunk/activemq-core/src/main/java/org/apache/activemq/kaha/MapContainer.java:140: error: name clash: remove(K) in MapContainer and remove(Object) in Map have the same erasure, yet neither overrides the other
        V remove(K key);
        ^

        [INFO] ------------------------------------------------------------------------
        [INFO] For more information, run Maven with the -e switch
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 1 minute 47 seconds
        [INFO] Finished at: Mon Aug 01 09:32:06 PDT 2011
        [INFO] Final Memory: 61M/438M
        [INFO] ------------------------------------------------------------------------

        Allen Reese added a comment -

        This patch fixes the access qualifiers in Usage.java, because JDK 7 has more strict checking here.

        In MapContainer.java it fixes the conflict with the Map interface that is extended to fix errors about generic type erasure.

        Allen Reese added a comment -

        3rd patch, pegs the maven-compiler-plugin at 2.3.2 which does a far better job of not croaking on jdk7 compiler messages.

        Dejan Bosanac added a comment -

        Fixed with svn revision 1153425. Thanks for patches!

        Allen Reese added a comment -

        mvn site works correctly now.

        Thanks.

        Allen Reese added a comment -

        Maven has released new jar/archiver versions that work better with jdk 7
        Reopening to attach a patch for that.

        Allen Reese added a comment - - edited

        Set archiver and jar plugin versions to the newly released versions that work better with jdk.

        AMQ-3427-archiver.patch

        Dejan Bosanac added a comment -

        Patch applied with svn revision 1163987. Thanks!

        Allen Reese added a comment -

        This is completed.


          People

          • Assignee:
            Dejan Bosanac
            Reporter:
            Allen Reese
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development