Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-3239

Jboss blocked in startup when messages are in the que

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.4.2
    • Fix Version/s: 5.9.0
    • Component/s: Connector
    • Labels:
      None
    • Environment:
      • Jboss 5.1.0 GA
      • Activemq 5.4.2

      Description

      Reproducing senario:
      1- Start activemq server
      2- With admin console send a message to testqueue (message is enqueued)
      3- Deploy activemq-ra.rar connector
      4- deploy an ear containing (an mdb to consume the message) and a simple application
      5- start jboss

      Always Jboss startup block after INFO [ra.ActiveMQEndpointWorker] Successfully established connection to broker [tcp://localhost:61616] and can't continue deployment of the ear which contain the mdb consumer

      Is there a specific config to do, to let activemq-ra.rar deployed without trying to send the pending message untill the server starup and that the mdb beying ready to consume it.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mahmoudmaalej Mahmoud maalej
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: