ActiveMQ
  1. ActiveMQ
  2. AMQ-3165

ActiveMQ 5.4.2 Admin - Accessing Scheduled.jsp giving an Exception in log file

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.4.2
    • Fix Version/s: 5.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Wndows XP / Oracle Persistence

      Description

      Whenever I access Scheduled.jsp through Admin Console.....in ActiveMQ.log...

      WARN | /admin/scheduled.jsp
      INFO | jvm 1 | 2011/01/27 18:46:20 | javax.el.ELException: java.lang.IllegalArgumentException: Null object name
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.el.BeanELResolver.getValue(BeanELResolver.java:298)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:175)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at com.sun.el.parser.AstValue.getValue(AstValue.java:138)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:206)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jasper.runtime.PageContextImpl.evaluateExpression(PageContextImpl.java:1001)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jsp.scheduled_jsp._jspx_meth_c_forEach_0(org.apache.jsp.scheduled_jsp:118)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jsp.scheduled_jsp._jspService(org.apache.jsp.scheduled_jsp:90)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:109)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:389)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:486)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:380)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:527)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1216)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.springframework.web.filter.RequestContextFilter.doFilterInternal(RequestContextFilter.java:83)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1187)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.web.SessionFilter.doFilter(SessionFilter.java:45)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1187)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.web.filter.ApplicationContextFilter.doFilter(ApplicationContextFilter.java:81)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1187)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1187)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:421)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:493)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:930)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:358)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:866)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:126)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:456)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:126)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:113)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.Server.handle(Server.java:351)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:594)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:1042)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:549)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:211)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:424)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:506)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:436)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at java.lang.Thread.run(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | Caused by: java.lang.IllegalArgumentException: Null object name
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.management.MBeanServerInvocationHandler.<init>(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.management.MBeanServerInvocationHandler.<init>(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.management.MBeanServerInvocationHandler.newProxyInstance(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.broker.jmx.ManagementContext.newProxyInstance(ManagementContext.java:290)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.web.LocalBrokerFacade.newProxyInstance(LocalBrokerFacade.java:88)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.web.BrokerFacadeSupport.getJobScheduler(BrokerFacadeSupport.java:206)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at org.apache.activemq.web.BrokerFacadeSupport.getScheduledJobs(BrokerFacadeSupport.java:210)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at java.lang.reflect.Method.invoke(Unknown Source)
      INFO | jvm 1 | 2011/01/27 18:46:20 | at javax.el.BeanELResolver.getValue(BeanELResolver.java:293)
      INFO | jvm 1 | 2011/01/27 18:46:20 | ... 46 more

        Activity

        Dejan Bosanac added a comment -

        This is duplicate of https://issues.apache.org/jira/browse/AMQ-3088, which is resolved on the trunk

        Gary Tully added a comment -

        workaround: scheduler support needs to be enabled for the broker. <broker schedulerSupport="true" ../>


          People

          • Assignee:
            Dejan Bosanac
            Reporter:
            Nageswara P Nakarikanti
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development