ActiveMQ
  1. ActiveMQ
  2. AMQ-3158

topics with durable subscribers don't indicate messages have dequeued in console

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.4.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows XP

      Description

      Once a durable subscriber is associated with a topic, the ActiveMQ console never shows messages have been dequeued. This problem occurs whether or not the durable subscriber is active. Only restarting ActiveMQ causes ActiveMQ console to show there are no enqueued messages in the topic.

      After reconfiguring ActiveMQ to use Oracle as the persistent store, I was able to verify messages successfully published to a durable subscriber are removed from the backing store. However, the ActiveMQ console continues to list them under enqueued messages.

        Activity

        Jane Eisenstein created issue -
        Claus Ibsen added a comment -

        Would this still be a problem with latest release? Any one reproduce this problem in a later release?

        Timothy Bish added a comment -

        No test code or update from reporter about this issue on a more current release.

        Timothy Bish made changes -
        Field Original Value New Value
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1022d 18h 41m 1 Timothy Bish 13/Nov/13 15:50

          People

          • Assignee:
            Unassigned
            Reporter:
            Jane Eisenstein
          • Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development