ActiveMQ
  1. ActiveMQ
  2. AMQ-2947

After a performance the server stop working. No errors send to the client.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not a Problem
    • Affects Version/s: 5.3.1
    • Fix Version/s: None
    • Component/s: Broker
    • Labels:
      None
    • Environment:

      linux

      Description

      When we start the performance test for ActiveMQ Server we send 2000 Messages to the Server via Stomp.
      When we send a block of 2000 messages four or five times the server produced an error into the log file.
      The client get no response for the failure.
      The Stack

      2010-09-23 11:26:22,916 | WARN | Async error occurred: javax.jms.JMSException: Unmatched acknowledege: MessageAck

      {commandId = 8296, responseRequired = false, ackType = 2, consumerId = ID:alinux1-54962-1284536721696-5:42:-1:1, firstMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, lastMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, destination = queue://LGDMessageRetTest, transactionId = null, messageCount = 1}

      ; Could not find Message-ID ID:alinux1-54962-1284536721696-5:35:-1:1:1293 in dispatched-list (start of ack) | org.apache.activemq.broker.TransportConnection.Service | ActiveMQ Transport: tcp:///10.200.30.158:63279
      javax.jms.JMSException: Unmatched acknowledege: MessageAck

      {commandId = 8296, responseRequired = false, ackType = 2, consumerId = ID:alinux1-54962-1284536721696-5:42:-1:1, firstMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, lastMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, destination = queue://LGDMessageRetTest, transactionId = null, messageCount = 1}

      ; Could not find Message-ID ID:alinux1-54962-1284536721696-5:35:-1:1:1293 in dispatched-list (start of ack)
      at org.apache.activemq.broker.region.PrefetchSubscription.assertAckMatchesDispatched(PrefetchSubscription.java:440)
      at org.apache.activemq.broker.region.PrefetchSubscription.acknowledge(PrefetchSubscription.java:208)
      at org.apache.activemq.broker.region.AbstractRegion.acknowledge(AbstractRegion.java:369)
      at org.apache.activemq.broker.region.RegionBroker.acknowledge(RegionBroker.java:470)
      at org.apache.activemq.broker.TransactionBroker.acknowledge(TransactionBroker.java:194)
      at org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:74)
      at org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:74)
      at org.apache.activemq.broker.MutableBrokerFilter.acknowledge(MutableBrokerFilter.java:85)
      at org.apache.activemq.broker.TransportConnection.processMessageAck(TransportConnection.java:449)
      at org.apache.activemq.command.MessageAck.visit(MessageAck.java:205)
      at org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:297)
      at org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:175)
      at org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
      at org.apache.activemq.transport.stomp.StompTransportFilter.sendToActiveMQ(StompTransportFilter.java:78)
      at org.apache.activemq.transport.stomp.ProtocolConverter.sendToActiveMQ(ProtocolConverter.java:135)
      at org.apache.activemq.transport.stomp.ProtocolConverter.onStompAck(ProtocolConverter.java:281)
      at org.apache.activemq.transport.stomp.ProtocolConverter.onStompCommand(ProtocolConverter.java:175)
      at org.apache.activemq.transport.stomp.StompTransportFilter.onCommand(StompTransportFilter.java:67)
      at org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
      at org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:203)
      at org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:185)
      at java.lang.Thread.run(Thread.java:619)

      mfg
      Christian Rams

        Activity

        Timothy Bish added a comment -

        Do you have a test case for this that can reproduce the issue. Any other supporting information to help test this out?

        Christian Rams added a comment -

        we do the test case with an smalltalk script.
        The error is fixed when we use oracle and the last Version

        Mit freundlichen Grüßen / Best regards / Meilleures salutations

        Christian Rams

        IT-Applications
        Societe Generale Equipment Finance
        GEFA Gesellschaft für Absatzfinanzierung mbH
        GEFA-Leasing GmbH
        Robert-Daum-Platz 1
        42117 Wuppertal

        Tel: +49 202 382 615
        Fax: +49 202 382 700615

        christian.rams@gefa.de
        http://www.gefa.de

        "Timothy Bish (JIRA)" <jira@apache.org>
        30.06.2011 00:36

        An
        Christian.Rams@Gefa.de
        Kopie

        Thema
        [jira] [Commented] (AMQ-2947) After a performance the server stop working.
        No errors send to the client.

        Bitte drucken Sie diese E-Mail nur dann aus, wenn es wirklich notwendig
        ist.

        [
        https://issues.apache.org/jira/browse/AMQ-2947?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13057521#comment-13057521
        ]

        Timothy Bish commented on AMQ-2947:
        -----------------------------------

        Do you have a test case for this that can reproduce the issue. Any other
        supporting information to help test this out?

        client.
        ---------------------------------------------------------------------------
        Messages to the Server via Stomp.
        produced an error into the log file.
        javax.jms.JMSException: Unmatched acknowledege: MessageAck

        {commandId = 8296, responseRequired = false, ackType = 2, consumerId = ID:alinux1-54962-1284536721696-5:42:-1:1, firstMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, lastMessageId = ID:alinux1-54962-1284536721696-5:35:-1:1:1293, destination = queue://LGDMessageRetTest, transactionId = null, messageCount = 1}

        ; Could
        not find Message-ID ID:alinux1-54962-1284536721696-5:35:-1:1:1293 in
        dispatched-list (start of ack) |
        org.apache.activemq.broker.TransportConnection.Service | ActiveMQ
        Transport: tcp:///10.200.30.158:63279
        8296, responseRequired = false, ackType = 2, consumerId =
        ID:alinux1-54962-1284536721696-5:42:-1:1, firstMessageId =
        ID:alinux1-54962-1284536721696-5:35:-1:1:1293, lastMessageId =
        ID:alinux1-54962-1284536721696-5:35:-1:1:1293, destination =
        queue://LGDMessageRetTest, transactionId = null, messageCount = 1}; Could
        not find Message-ID ID:alinux1-54962-1284536721696-5:35:-1:1:1293 in
        dispatched-list (start of ack)
        org.apache.activemq.broker.region.PrefetchSubscription.assertAckMatchesDispatched(PrefetchSubscription.java:440)
        org.apache.activemq.broker.region.PrefetchSubscription.acknowledge(PrefetchSubscription.java:208)
        org.apache.activemq.broker.region.AbstractRegion.acknowledge(AbstractRegion.java:369)
        org.apache.activemq.broker.region.RegionBroker.acknowledge(RegionBroker.java:470)
        org.apache.activemq.broker.TransactionBroker.acknowledge(TransactionBroker.java:194)
        org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:74)
        org.apache.activemq.broker.BrokerFilter.acknowledge(BrokerFilter.java:74)
        org.apache.activemq.broker.MutableBrokerFilter.acknowledge(MutableBrokerFilter.java:85)
        org.apache.activemq.broker.TransportConnection.processMessageAck(TransportConnection.java:449)
        org.apache.activemq.command.MessageAck.visit(MessageAck.java:205)
        org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:297)
        org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:175)
        org.apache.activemq.transport.TransportFilter.onCommand(TransportFilter.java:68)
        org.apache.activemq.transport.stomp.StompTransportFilter.sendToActiveMQ(StompTransportFilter.java:78)
        org.apache.activemq.transport.stomp.ProtocolConverter.sendToActiveMQ(ProtocolConverter.java:135)
        org.apache.activemq.transport.stomp.ProtocolConverter.onStompAck(ProtocolConverter.java:281)
        org.apache.activemq.transport.stomp.ProtocolConverter.onStompCommand(ProtocolConverter.java:175)
        org.apache.activemq.transport.stomp.StompTransportFilter.onCommand(StompTransportFilter.java:67)
        org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:84)
        org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:203)
        org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:185)


        This message is automatically generated by JIRA.
        For more information on JIRA, see: http://www.atlassian.com/software/jira

        2010 European Lessor of the Year and Vendor Finance Provider of the Year Awards by Leasing Life

        GEFA Gesellschaft für Absatzfinanzierung mbH, Robert-Daum-Platz 1, 42117 Wuppertal
        Aufsichtsratsvorsitzender: Didier Hauguel, Geschäftsführer: Maurice Caulliez, Rolf Hagen, Jochen Jehmlich
        HRB Nr. 2708, Amtsgericht Wuppertal

        GEFA-Leasing GmbH, Robert-Daum-Platz 1, 42117 Wuppertal
        Beiratsvorsitzender: Didier Hauguel, Geschäftsführer: Maurice Caulliez, Rolf Hagen, Jochen Jehmlich
        HRB Nr. 3619, Amtsgericht Wuppertal

        Diese E-Mail enthält vertrauliche und/oder rechtlich geschützte Informationen. Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich erhalten haben, informieren Sie bitte sofort den Absender und vernichten Sie diese Mail. Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail ist nicht gestattet.

        This message and any attachments (the "message") are confidential, intended solely for the addressee(s), and may contain legally privileged information. any unauthorised use or dissemination is prohibited. E-Mails are susceptible to alteration. Neither GEFA nor any of its subsidiaries or affiliates shall be liable for the message if altered, changed or falsified.

        Timothy Bish added a comment -

        Reported to be fixed by the initial issue creator.


          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Rams
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development