ActiveMQ
  1. ActiveMQ
  2. AMQ-2856

m2eclipse fails to update maven project configuration

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      ubuntu 10.4, java6, eclipse 3.4, m2eclipse 0.10.2.20100623-1649

    • Patch Info:
      Patch Available

      Description

      If you try to "Update Project Configuration" via m2eclipse plugin you see the following error:

      [ERROR] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version @ org.apache.activemq:apache-activemq:5.4-SNAPSHOT, /home/maurer/workspace2/activemq-trunk/assembly/pom.xml

      This is caused because the dependecy of org.osgi.core is specified two times (with different qualifiers). m2eclipse is really strict on that.

        Activity

          People

          • Assignee:
            Dejan Bosanac
            Reporter:
            Norman Maurer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development