ActiveMQ
  1. ActiveMQ
  2. AMQ-2853

Inflight count increases when subscribing to topic using '>' on destiantion name.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Implemented
    • Affects Version/s: 5.3.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
      2.6.18-194.el5 #1 SMP
      x86_64

      Description

      When subscribing to a topic using the '>' selector, the inflight counter for the affected (sub)topics increases with every message sent.
      However, the listeners receive the message correctly.

      You can easily reproduce this by starting two producers on A.B and A.C.

      If you subscribe using a MessageListener to 'A.>' you will see the increasing Inflight counter.

      This does not happen when subscribing directly to the topic. I.e. using two MessageListeners.

        Activity

        Claus Ibsen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Implemented [ 10 ]
        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Felix Ehm added a comment -

        It seems that 5.4.1 has solved this issue.

        However, I can't really reproduce it, because the InflightCount has been removed in the latest version.

        Felix Ehm made changes -
        Field Original Value New Value
        Description When subscribing to a topic using the '>' selector, the inflight counter for the affected (sub)topics are affected.

        You can easily reproduce this by starting two producers on A.B and A.C.

        If you subscribe using a MessageListener to 'A.>' you will see the increasing Inflight counter.


        This does not happen when subscribing directly to the topic. I.e. using two MessageListeners.
        When subscribing to a topic using the '>' selector, the inflight counter for the affected (sub)topics increases with every message sent.
        However, the listeners receive the message correctly.

        You can easily reproduce this by starting two producers on A.B and A.C.

        If you subscribe using a MessageListener to 'A.>' you will see the increasing Inflight counter.


        This does not happen when subscribing directly to the topic. I.e. using two MessageListeners.
        Priority Major [ 3 ] Minor [ 4 ]
        Felix Ehm created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Felix Ehm
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development