ActiveMQ
  1. ActiveMQ
  2. AMQ-2846

Apache Camel Activemq component does not allow use of "consumer.retroactive=true"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.3.2
    • Fix Version/s: 5.6.0
    • Component/s: None
    • Labels:
      None

      Description

      I am not entirely certain if this belongs here or in Camel, but use of the parameter"...?consumer.retroactive=true" while using the Activemq component in camel throws the following:

      Failed to resolve endpoint: activemq://topic:foo.bar?consumer.retroactive=true due to: There are 1 parameters that couldn't be set on the endpoint. Check the uri if the parameters are spelt correctly and that they are properties of the endpoint. Unknown parameters=[

      {consumer.retroactive=true}

      ]

      Excerpt from dsl:
      <camelContext xmlns="http://camel.apache.org/schema/spring">
      <route>
      <from uri="activemq:topic:foo.bar?consumer.retroactive=true" />

      It seems odd that this would be left out.

        Activity

        Brian created issue -
        Brian added a comment -

        Initial indications seem to suggest this might work.

        <bean id="jmsFactory" class="org.apache.activemq.ActiveMQConnectionFactory">
        <property name="brokerURL">
        <value>failover://(tcp://localhost:61616)</value>
        </property>
        <property name="useRetroactiveConsumer">
        <value> true </value>
        </property>
        </bean>

        Still it would be better (IMO) that this be able to use as suggested above as a parameter.

        -Brian

        Jeff Turner made changes -
        Field Original Value New Value
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Timothy Bish added a comment -

        Duplicate of AMQ-3498. Fixed

        Timothy Bish made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 5.6.0 [ 12316331 ]
        Resolution Duplicate [ 3 ]
        Gary Tully added a comment -

        reopen to set fix version to 5.6

        Gary Tully made changes -
        Resolution Duplicate [ 3 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Gary Tully added a comment -

        closing again with correct fix version

        Gary Tully made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 5.6.0 [ 12317974 ]
        Fix Version/s 5.x [ 12316331 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Brian
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development