ActiveMQ
  1. ActiveMQ
  2. AMQ-2682

apr_version and apu_version issues (apr) in configure file

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.4.0
    • Component/s: CMS (C++ client)
    • Labels:
      None
    • Environment:

      Red Hat Enterprise 5, after installation of apache 2.2 (http-2.2.15)

      Description

      I was having difficulty running ./configure to set up ActiveMQ. I am running Red Hat Linux Enterprise 5 at Sandia National Labs.

      There were two problems. First, the apr version I had on my machine, after installing apache web server 2.2, was version 1.4.2. The variable APR_VER_REGEXES was set up so 1.3.* was expected, and 1.4.* was not. The documentaion indicates that version 1.4.2 should be sufficiently advanced.

      Second, the apr util version I had was 1.3.9. When I changed APR_VER_REGEXES to expect 1.4., it started reporting that I had the wrong apr util version, even though I still had APU_VER_REGEXES set to expect 1.3.

      It turned out that there was an incorrect line, which worked okay if apr and apr util had the same version. The original line was:
      if test `expr $apr_version : $apu_wanted_regex` -ne 0; then
      the corrected line is
      if test `expr $apu_version : $apu_wanted_regex` -ne 0; then

      notice that the apr version (apr_version) was being compared to the apr util expected regular expression (apu_wanted_regex). I fixed it by changing apr_version in the line to apu_version.

        Activity

        Jeff Mauldin created issue -
        Rob Davies made changes -
        Field Original Value New Value
        Fix Version/s 5.4.1 [ 12332 ]
        Timothy Bish made changes -
        Assignee Timothy Bish [ tabish121 ]
        Timothy Bish made changes -
        Fix Version/s 5.4.1 [ 12332 ]
        Component/s CMS (C++ client) [ 11571 ]
        Fix Version/s 5.4.0 [ 12110 ]
        Timothy Bish made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]

          People

          • Assignee:
            Timothy Bish
            Reporter:
            Jeff Mauldin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development