ActiveMQ
  1. ActiveMQ
  2. AMQ-2581

ActiveMQ Web Console Integration with Tomcat (5.0.28)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 5.3.0
    • Fix Version/s: 5.9.0
    • Component/s: webconsole
    • Labels:
      None
    • Environment:

      OS: Solaris 10, JDK: Java 1.5.0_12, Tomcat (5.0.28), ActiveMQ (5.3)

      Description

      After integration the ActieMQ Web Console (activemq-web-console.war) with Tomcat, I am able to view the web console. However, when I click on the Connectors Menu, I get the following error message displayed in Tomcat:

      message
      description The server encountered an internal error () that prevented it from fulfilling this request.

      exception
      javax.servlet.ServletException: javax.servlet.jsp.el.ELException: An error occurred while getting property "connectors" from an instance of class org.apache.activemq.web.RemoteJMXBrokerFacade
      org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:821)
      org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:758)
      org.apache.jsp.connections_jsp._jspService(connections_jsp.java:108)
      org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:324)
      org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
      org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      org.springframework.web.filter.RequestContextFilter.doFilterInternal(RequestContextFilter.java:83)
      org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      org.apache.activemq.web.SessionFilter.doFilter(SessionFilter.java:43)
      org.apache.activemq.web.filter.ApplicationContextFilter.doFilter(ApplicationContextFilter.java:81)
      com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
      com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

      root cause
      java.lang.IllegalStateException: not supported
      org.apache.activemq.web.RemoteJMXBrokerFacade.getManagementContext(RemoteJMXBrokerFacade.java:215)
      org.apache.activemq.web.BrokerFacadeSupport.getConnectors(BrokerFacadeSupport.java:148)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.apache.commons.el.ArraySuffix.evaluate(ArraySuffix.java:314)
      org.apache.commons.el.ComplexValue.evaluate(ComplexValue.java:145)
      org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:263)
      org.apache.commons.el.ExpressionEvaluatorImpl.evaluate(ExpressionEvaluatorImpl.java:190)
      org.apache.jasper.runtime.PageContextImpl.proprietaryEvaluate(PageContextImpl.java:899)
      org.apache.jsp.connections_jsp._jspx_meth_c_forEach_0(connections_jsp.java:123)
      org.apache.jsp.connections_jsp._jspService(connections_jsp.java:73)
      org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:324)
      org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
      org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      org.springframework.web.filter.RequestContextFilter.doFilterInternal(RequestContextFilter.java:83)
      org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      org.apache.activemq.web.SessionFilter.doFilter(SessionFilter.java:43)
      org.apache.activemq.web.filter.ApplicationContextFilter.doFilter(ApplicationContextFilter.java:81)
      com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
      com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

        Activity

        Koen Maes added a comment -

        the old webconsole is deprecated...
        what do you expect ... the bug was open for 3.5 years.
        ActiveMQ will soon be deprecated.

        Claus Ibsen added a comment -

        The old web console is deprecated. From 5.9 there is a new console that works in Tomcat and other containers.

        Koen Maes added a comment -

        same here

        • tomcat 5.5.28
        • solaris 10
        • servicemix/activemq
        • Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
        Bertrand GILLIS added a comment -

        Same issue for me with

        • JBoss AS 5.1.0
        • Sun JDK 1.6.0_18
        • Windows XP SP3 32-bit

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Reji Nair
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development