ActiveMQ
  1. ActiveMQ
  2. AMQ-2502

activemq-camel is missing an optional Import-Package for org.apache.activemq.pool

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.0, 5.3.0
    • Fix Version/s: 5.3.1, 5.4.0, 5.6.0
    • Component/s: None
    • Labels:
      None
    • Regression:
      Regression

      Description

      If pooling is used, org.apache.activemq.pool.PooledConnectionFactory is instantiated using reflection. BND does not detect this, so compliant OSGI containers will throw a class not found exception. To fix, the following line should be added to the <activemq.osgi.import.pkg /> section of the pom:

      org.apache.activemq.pool;resolution:=optional,

        Issue Links

          Activity

          Gary Tully added a comment -

          applied suggestion in r882136, thanks.

          Gary Tully added a comment -

          this seems to have regressed via https://issues.apache.org/jira/browse/AMQ-3463

          optional imports are missing again.

          Jonathan Anstey added a comment -

          I'm wondering about this one... in 5.6 with the new optional dependency on activemq-pool, now Maven users the activemq-camel component will fail OOTB. The default behavior is to use pooling, so it isn't an optional dependency by default The workaround right now is to always depend on activemq-pool when using activemq-camel.

          Maybe we should remove that optional tag from the activemq-pool Maven dependency? WDYT?

          Timothy Bish added a comment -

          I'd agree with this, the optional bit seems a bit odd since its pretty much a requirement.

          Gary Tully added a comment -

          the workaround is to manually install the activemq-pool bundle:

          >osgi:install activemq-pool
          Claus Ibsen added a comment -

          I am adding activemq-pool as required dep for activem-camel again. Just as it used to be in 5.5.1 or older.
          See ticket AMQ-3847.

          Any objections?


            People

            • Assignee:
              Gary Tully
              Reporter:
              Phil Messenger
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development