ActiveMQ
  1. ActiveMQ
  2. AMQ-2453

start/control-script is not suitable for professional environments

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.3.0
    • Fix Version/s: NEEDS_REVIEW
    • Component/s: Broker
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Regression:
      Regression

      Description

      The start-scripts "activemq" and "activemq-admin" do not seem to be ready for production use.

      Reasons:

      • Server does not run in background
        => this can be done by redirecting output to a file and run in background
        => in my opinion this should be implemented directly in java
        => the console log should be written by log4j to <install-root>/data/console.log
      • The process should be started on a non-root user
        => use 'su -c "$COMMAND" - $RUN_AS_USER'
        => this should be defined in /etc/activemq.conf
      • The script should support a "reload" feature to reload the configurartion
        (if activemq supports reloading)
      • The script should support a "status" option
        => this should show a quick overview about the state of activemq
        => this should return a value != 0 if the service is not working
        (this is important for cluster integration)

      Does anybody already working on these items?
      Do you have suggestions for a implementation?

      1. usage-example.txt
        26 kB
        Marc Schöchlin
      2. activemq
        18 kB
        Marc Schöchlin

        Issue Links

          Activity

          Marc Schöchlin added a comment -

          I wrote a new initscript for running standalone activemq installations
          (see attached script).

          This script is originally based on the scripts "activemq" and
          "activemq-admin" located in
          "assembly/src/release/bin/" and replaces both scripts.

          Read "usage-examples.txt" for getting a first impression of the initscript.

          Features of the new script:

          • the script should be compatible with cygwin, macosx and most linux and
            unix systems
            To ensure compatibility to macosx and cygwin it does not utilize lsb
            standard infrastructure for controlling daemons like
            "start-stop-daemon".
            (i tried to keep the shell-syntax compatible to most unix systems,
            but only tested on SLES11 and Ubuntu 9.10)
          • the complete functionality if "activemq-admin" is now included in
            "activemq"
            (list, query, browse, ...)
          • all option not implemented by the initscript, are directly passed to
            the java-call
          • the configuration parameters can be located in
            /etc/default/activemq.conf or $HOME/.activemqrc
          • the script supports operation of multiple instances on the same system
            (if the script is symlinked/renamed to
            "activemq-instance-<INSTANCENAME>", the configuration
            is searched on /etc/default/activemq-instance-<INSTANCENAME>.conf and
            $HOME/.activemqrc-instance-<INSTANCENAME>)
          • in case of syntax-errors in the configuration, the execution is stopped
          • a template configuration for the script can be created by using the
            "setup" option
          • activemq configuration- and data-dir (e.g. kahadb, tmpstorage) are
            configurable
          • configuration hints for jmx (because of non-available
            "VirtualMachine.attach(PID)", especially needed when using a ibm jvms)
          • improved shutdown procedure: script invokes shutdown by a jmx-request,
            if process does not disappear
            after a configurable timeout, the process is killed by SIGKILL (-9)
          • start activemq daemon as an background process : option "start"
          • start activemq daemon without daemonizing the daemon: option "fgstart"
          • usage of PID files to determine running activemq instances
          • the "status" option, checks if there is a running activemq instance
            (this is useful for using activemq with high-availability tools)
          • the script outputs usage-information if it is invoked without any option
            (usage of the java binary combined with the script-usage)

          In my opinion it would be good/nice:

          • if this script is will be tested on several unix-systems and on cygwin
          • to provide the possibility to configure the entire jmx-setup in
            activemq.xml or jetty.xml
            (if jetty provides this)
          • it would be nice if the java code supports daemonizing
          • if this script will be part of activemq, we should adapt the wiki pages

          Feedback and improvement ideas are very welcome

          Marc Schöchlin added a comment -

          Removed a typo

          Marc Schöchlin added a comment -
          • Enhanced function documentation
          • removed some typos
          Marc Schöchlin added a comment -

          Relocated /etc/default/activemq.conf to /etc/default/activemq

          Rob Davies added a comment -

          Marc,
          this is really great!
          Question - what do you mean by nice if java code supported daemonizing ?

          Dirk de Kok added a comment -

          hi there,

          I had a short look a the script here and the activemq site (http://activemq.apache.org/unix-service.html). For me as a software engineer and not system engineer it is a bit difficult to say what the best way is, but this is my input:

          • process should run like a daemon in the background
          • process should do proper logging
          • process should be available for status checks (e.g. via jmx)
          • process should run like a specified user (e.g. activemq) and not root
          • should use PID file
          • should be possible to configure for automatic startup and shutdown

          What I miss right now (but might have overlooked):

          • example directory layout (where binaries, config files, startup script)
          • clear definition of responsibilities of files (controlling process, configuration, etc). Right now too much is in some files
          • how to install for automatic startup/shutdown with the system (on linux for me in particular)

          just my 2 cents

          dirk

          Marc Schöchlin added a comment -

          Response to:

          Rob Davies added a comment - 15/Jan/10 02:04 PM
          Question - what do you mean by nice if java code supported daemonizing ?

          • The jetty process should detach STDOUT/STDERR on starting
          • The jetty process should start as background process
          Marc Schöchlin added a comment -

          Response to: Dirk de Kok :

          • process should run like a daemon in the background
          • process should do proper logging
          • process should be available for status checks (e.g. via jmx)
          • process should run like a specified user (e.g. activemq) and not root
          • should use PID file
          • should be possible to configure for automatic startup and shutdown

            => This is already supported by the attached init-script, but it would be better to implement this directly in java
            (and not by using system-properties and shell-tricks)

          Additional comments:

          • example directory layout (where binaries, config files, startup script)
            => just invoke the script without any parameters, you will see some documentation
            => invoke the script with the setup option (./activemq status /path/to/file) and you get a example configuration file
          • clear definition of responsibilities of files (controlling process, configuration, etc). Right now too much is in some files
            => i agree, this can be improved by implementing more functionality of the script directly in activemq
          • how to install for automatic startup/shutdown with the system (on linux for me in particular)
            => this is already documented in the init-documentation of your linux-os
          David J. M. Karlsen added a comment -
          Marc Schöchlin added a comment -

          We should remove jsw wrapper scripts - this is a ugly solution from a linux/unix sysadmin's view....popular projects like tomcat and jboss
          also do not need hacks like this....

          See also: https://issues.apache.org/activemq/browse/AMQ-2105?focusedCommentId=59373&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_59373

          Dejan Bosanac added a comment -

          A modified script has been committed with svn revision 956005

          I made a few changes:

          • copied the part from the old script that sets ACTIVEMQ_HOME to the current dir if it isn't already set and /opt/activemq does not exists
          • refactored around seq as it does not exists on OS X
          • added logic to create data folder if it doesn't exist (maybe this can be made even more bulletproof)
          • used bash as echo -n is bash specific
          • fixed some typos

          This is only the starting point, so we should test this thoroughly in various environments and make it rock solid for the next release (I tested it so far on OS X)

          The one thing I observed is that we need to improve the stop logic as "regular stop method" isn't called asynchronously, so the waiting loop doesn't do much.

          Thanks for the contribution Marc.

          Dejan Bosanac added a comment -

          Fixed with svn revision 959227.

          I incorporated couple of improvements and tested on OS X, Ubuntu and Cygwin.

          Important thing to note is that when used on Cygwin, you should explicitly turn on JMX, like

                  <managementContext>
                      <managementContext createConnector="true"/>
                  </managementContext>
          

          as connecting to pid works only on linux. This should be documented in the upcoming docs.

          Marc Schöchlin added a comment - - edited

          Thats right, "VirtualMachine.attach(PID)" also does not work with a IBM JVM (we are using activemq with a IBM JVM on a IBM Mainframe/System z Linux).

          Maybe there is a jmx connector for a unix domain socket file available?

          This might be very cool from a system administrator´s view - because :

          • you don´t need to open and secure (ssl, accounts, passwords, ...) a tcp port
          • it is possible to control permissions by simple file permissions
          • simple configuration of the initscript

          Best regards
          Marc

          Dejan Bosanac added a comment -

          Yeah, it'd be very useful, but I'm not aware of such a thing

          Marc Schöchlin added a comment -

          With activemq 5.4.1 the new initscript is part of the activemq distribution.

          There are still parts of the old start/control-script infrastructure for unix/linuxmacos systems
          included in the activemq delivery.

          This should be removed, because this confuses activemq-users.

          Distribution should not contain the follwing folders/files:

          apache-activemq-5.4.1/bin/activemq-admin : All functionality of bin/activemq-admin is implemented in bin/activemq
          apache-activemq-5.4.1/bin/linux-x86-32 : This is only needed for jsw
          apache-activemq-5.4.1/bin/linux-x86-64 : This is only needed for jsw
          apache-activemq-5.4.1/bin/macosx : This is only needed for jsw
          apache-activemq-5.4.1/bin/wrapper.jar : This is only needed for jsw

          In my current work-environment admins and developers were confused of having two different start environments - i think
          it´s a good idea to cleanup the distribution.

          Regards
          Marc

          Gary Tully added a comment -

          The script needs to confine its self to /bin/sh features. It needs to work out of the box on aix.

          Marc Schöchlin added a comment -

          Sorry, i don't own a aix system

          Probably its enough to modify the sheebang like this:


          $ svn diff
          Index: activemq
          ===================================================================
          — activemq (Revision 1021620)
          +++ activemq (Arbeitskopie)
          @@ -1,4 +1,4 @@
          -#!/bin/bash
          +#!/usr/bin/env bash

          1. ------------------------------------------------------------------------
          2. Licensed to the Apache Software Foundation (ASF) under one or more
          3. contributor license agreements. See the NOTICE file distributed with

          Bash emulation of /bin/sh is often not completely compatible to the "sh" of legacy unix systems - but most
          of these systems provide the bash shell. Can you sent me the following information:

          • stdout/stderr output of a script feature which is not working using "/bin/sh activemq"
          • stdout/stderr output of a script feature which is not working with "/bin/sh -x activemq"
          Norman Maurer added a comment -

          The script should only use basic shell stuff which is usable with a ksh. Bash is not installed on some unix like operation systems out of the box (for example freebsd). So you should use #!/bin/sh and make it work with it.

          Just my 2 cents

          Marc Schöchlin added a comment -

          Rewriting shellscript to run with ksh might be real pain - because the implementation of ksh/sh varies between systems.
          (i.e. between K&R and Sun ksh)

          /bin/sh does also not provide real portability for complexer functions - the behavior of /bin/sh varies between systems.

          I really think it is no real pain to run this script in bash because bash is available on all commodity unix-systems.

          At least Linux, AIX and Solaris provide a preinstalled bash for years now.

          BTW: If there are problems on other platforms i can rewrite the code if you can send me the debugging output of the shell (bash -x).

          The new script is an advantage over the old mechanism because the old mechanism only supported linux and macos...

          Dejan Bosanac added a comment -

          Portability issue fixed with svn revision 1034453

          I tested it on osx, various dists of linux, aix and solari. It looks ok now. More testing is definitely welcomed.

          Marc Schöchlin added a comment -

          The script is included in the distribution.

          Why not removing apache-activemq-5.5.1/bin/

          {activemq-admin,linux-x86-32,linux-x86-64,macosx,wrapper.jar}

          ?

          The unix script does not utilize these files - and apache-activemq-5.5.1/bin/activemq contains all
          features of apache-activemq-5.5.1/bin/activemq-admin

          Marc Schöchlin added a comment -

          Please remove the no longer needed files apache-activemq-5.x.x/bin/

          {activemq-admin,linux-x86-32,linux-x86-64,macosx,wrapper.jar}

          Please add the script header to the script apache-activemq-5.x.x/bin/activemq to prevent SLES systems to complain about
          broken lsb-headers

          insserv: missing `Required-Stop:'  entry: please add even if empty.
          insserv: warning: script 'activemq' missing LSB tags and overrides
          insserv: warning: script 'activemq' missing LSB tags and overrides
          insserv: Default-Start undefined, assuming default start runlevel(s) for script `activemq'
          

          Script header:

          #!/bin/sh
          
          ### BEGIN INIT INFO
          # Provides:          activemq
          # Required-Start:    $remote_fs $network $syslog
          # Required-Stop:     $remote_fs $network $syslog
          # Default-Start:     3 5
          # Default-Stop:      0 1 6
          # Short-Description: Starts ActiveMQ
          # Description:       Starts ActiveMQ Message Broker Server
          ### END INIT INFO
          
          Marc Schöchlin added a comment -

          See last comment - remove the artifacts of the old start mechanism.
          Add the script header.

          Timothy Bish added a comment -

          Added LSB compliant header to the scripts for systems that use it.

          Marc Schöchlin added a comment -

          There are various references to the old activemq-admin script:

          http://activemq.apache.org/activemq-command-line-tools-reference.html

          It would be a good idea to add a disclaimer that this tool was replaced by "bin/activemq".

          The new command is not documented in a good way (http://activemq.apache.org/unix-shell-script.html)
          See comment of "11/Nov/09 18:53" for improvement.

          Another problem:
          I discovered that the "setup" option seems to create a strange init-script-configuration file. It differs very much from the initial behavior.

          I you provide access to the wiki, i will improve the documentation.

          Timothy Bish added a comment -

          You need to follow the process to submit you ICLA to Apache and appear on the unlisted CLA list then submit a request on the mailing list to be granted karma for your user account on the wiki.

          http://www.apache.org/licenses/

          Marc Schöchlin added a comment -

          I submitted the ICLA and get the confirmation the the ICLA is filed.

          If necessary and useful, i can provide documentation for wiki regarding the init-script and fixes for the init script

          Timothy Bish added a comment -

          In order to gain edit access you should create an account on the confluence Wiki and then send an email to the dev forum requesting karma to edit. Your account should be linked to the same email that's associated with your ICLA so we can match them up.


            People

            • Assignee:
              Timothy Bish
              Reporter:
              Marc Schöchlin
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development