ActiveMQ
  1. ActiveMQ
  2. AMQ-2353

Files was unexpected at this time error - while starting activemq service on windows 2003 64 bits machine

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 5.1.0
    • Fix Version/s: 5.6.0
    • Component/s: Broker
    • Labels:
      None
    • Environment:

      windows 2003 64 bits machine

    • Regression:
      Unit Test Broken

      Description

      Hi,
      I am trying to start activemq service on the windows 2003 enterprise server on 64 bits machine.

      I get following error while running activemq-admin.bat and activemq.bat

      was unexpected at this time error

      Kindly help me resolve this issue.

      Thanks & Regards,
      pankaj

        Activity

        Gary Tully added a comment -

        replace the first line of activemq,bat, "echo off" with "echo on" and post the output of an execution to see which part of the script has a problem.

        Rob Davies added a comment -

        We really need more information if we are expected to verify or reproduce this

        Rizal Sulong added a comment -

        This logs after I put echo on

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>activemq.ba
        t

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM -------
        -----------------------------------------------------------------

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM License
        d to the Apache Software Foundation (ASF) under one or more

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM contrib
        utor license agreements. See the NOTICE file distributed with

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM this wo
        rk for additional information regarding copyright ownership.

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM The ASF
        licenses this file to You under the Apache License, Version 2.0

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM (the "L
        icense"); you may not use this file except in compliance with

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM the Lic
        ense. You may obtain a copy of the License at

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM http://
        www.apache.org/licenses/LICENSE-2.0

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM Unless
        required by applicable law or agreed to in writing, software

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM distrib
        uted under the License is distributed on an "AS IS" BASIS,

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM WITHOUT
        WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM See the
        License for the specific language governing permissions and

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM limitat
        ions under the License.

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>REM -------
        -----------------------------------------------------------------

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>if exist "\
        activemqrc_pre.bat" call "\activemqrc_pre.bat"

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>if "Windows
        _NT" == "Windows_NT"

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>rem C:_Riz
        al\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin\ is expanded pathn
        ame of the current script under NT

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>set DEFAULT
        _ACTIVEMQ_HOME=C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\
        bin\..

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>if "" == ""
        set ACTIVEMQ_HOME=C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.
        1.0\bin\..

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>set DEFAULT
        _ACTIVEMQ_HOME=

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>rem find AC
        TIVEMQ_HOME if it does not exist due to either an invalid value passed

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>rem by the
        user or the activemq.bat problem on Windows 9x

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>if exist "C
        :_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin\..\README.tx
        t" goto checkJava

        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>set _JAVACM
        D=
        Files was unexpected at this time.
        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>if ""C:\Pro
        gram Files (x86)\Java\jdk1.6.0_12"" == "" goto noJavaHome
        C:_Rizal\Server\apache-activemq-5.1.0-bin\apache-activemq-5.1.0\bin>

        Timothy Bish added a comment -

        From the output it appears that the JAVA_HOME value is not set correctly so the script can't find a java executable to run the broker. Ensure that the environment vars are set correctly for the user you are trying to run the scripts as and this should be fixed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Pankaj Kumar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development