ActiveMQ
  1. ActiveMQ
  2. AMQ-2299

Integration Fails in jboss-5.0.0.GA

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.2.0
    • Fix Version/s: AGING_TO_DIE
    • Component/s: None
    • Labels:
      None
    • Environment:

      java version "1.5.0_19", Windows XP,

      Description

      Hi,

      I have downloaded activemq-ra.rar and activemq-jms-ds from http://activemq.apache.org/integrating-apache-activemq-with-jboss.html and placed in C:\work\jboss-5.0.0.GA\server\default\deploy. After that i have restarted the JBOSS server and i got the following messages in log file.

          • CONTEXTS MISSING DEPENDENCIES: Name -> Dependency {Required State:Actual State}

      activemq.queue:name=outboundQueue
      -> jboss.jca:name='activemq-ra.rar',service=RARDeployment

      {Create:** NOT FOUND Depends on 'jboss.jca:name='activemq-ra.rar',service=RARDeployment' **}

      activemq.topic:name=inboundTopic
      -> jboss.jca:name='activemq-ra.rar',service=RARDeployment

      {Create:** NOT FOUND Depends on 'jboss.jca:name='activemq-ra.rar',service=RARDeployment' **}

      jboss.jca:name=activemq/QueueConnectionFactory,service=ConnectionFactoryBinding
      -> jboss.jca:name=activemq/QueueConnectionFactory,service=TxCM

      {Create:Configured}

      jboss.jca:name=activemq/QueueConnectionFactory,service=ManagedConnectionFactory
      -> jboss.jca:name='activemq-ra.rar',service=RARDeployment

      {Create:** NOT FOUND Depends on 'jboss.jca:name='activemq-ra.rar',service=RARDeployment' **}

      jboss.jca:name=activemq/QueueConnectionFactory,service=ManagedConnectionPool
      -> jboss.jca:name=activemq/QueueConnectionFactory,service=ManagedConnectionFactory

      {Create:Configured}

      jboss.jca:name=activemq/QueueConnectionFactory,service=TxCM
      -> jboss.jca:name=activemq/QueueConnectionFactory,service=ManagedConnectionPool

      {Create:Configured}

      jboss.jca:name=activemq/TopicConnectionFactory,service=ConnectionFactoryBinding
      -> jboss.jca:name=activemq/TopicConnectionFactory,service=TxCM

      {Create:Configured}

      jboss.jca:name=activemq/TopicConnectionFactory,service=ManagedConnectionFactory
      -> jboss.jca:name='activemq-ra.rar',service=RARDeployment

      {Create:** NOT FOUND Depends on 'jboss.jca:name='activemq-ra.rar',service=RARDeployment' **}

      jboss.jca:name=activemq/TopicConnectionFactory,service=ManagedConnectionPool
      -> jboss.jca:name=activemq/TopicConnectionFactory,service=ManagedConnectionFactory

      {Create:Configured}

      jboss.jca:name=activemq/TopicConnectionFactory,service=TxCM
      -> jboss.jca:name=activemq/TopicConnectionFactory,service=ManagedConnectionPool

      {Create:Configured}
          • CONTEXTS IN ERROR: Name -> Error

      jboss.jca:name='activemq-ra.rar',service=RARDeployment -> ** NOT FOUND Depends on 'jboss.jca:name='activemq-ra.rar',service=RARDeployment' **

      vfsfile:/C:/work/jboss-5.0.0.GA/server/default/deploy/activemq-ra.rar/ -> java.io.IOException: The filename, directory name, or volume label syntax is incorrect

      However activemq is up and running in JBOSS 4.0.4.

      Please provide the solution.

      Thanks
      Veda

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1770d 16h 21m 1 Hadrian Zbarcea 29/Apr/14 12:19
        Hadrian Zbarcea made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Hadrian Zbarcea added a comment -

        Seems to not be a problem anymore.

        Timothy Bish made changes -
        Fix Version/s AGING_TO_DIE [ 12315631 ]
        Fix Version/s 5.x [ 12316331 ]
        Gary Tully made changes -
        Fix Version/s 5.6.0 [ 12316331 ]
        Fix Version/s 5.5.0 [ 12315626 ]
        Dejan Bosanac made changes -
        Fix Version/s 5.5.0 [ 12315626 ]
        Fix Version/s 5.4.2 [ 12315625 ]
        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Edison Melo added a comment - - edited

        Please forgive me if this is the wrong procedure... I'm just trying to help. The following works for me (JBoss 5.1, AMQ 5.3.2). Change this:

        <!DOCTYPE connection-factories
        PUBLIC "-//JBoss//DTD JBOSS JCA Config 1.5//EN"
        "http://www.jboss.org/j2ee/dtd/jboss-ds_1_5.dtd">

        <depends optional-attribute-name="RARName">jboss.jca:service=RARDeployment,name='activemq-ra.rar'</depends>

        For this:

        <!DOCTYPE connection-factories
        PUBLIC "-//JBoss//DTD JBOSS JCA Config 5.0//EN"
        "http://www.jboss.org/j2ee/dtd/jboss-ds_5_0.dtd">

        <depends optional-attribute-name="RARName">jboss.jca:name='activemq-rar.rar',service=RARDeployment</depends>

        After this changes, no errors in deploy an I can see the queue in the global JNDI.

        Bruce Snyder made changes -
        Fix Version/s 5.4.1 [ 12332 ]
        Fix Version/s 5.5.0 [ 12344 ]
        Rob Davies made changes -
        Field Original Value New Value
        Fix Version/s 5.4.1 [ 12332 ]
        vedavathi created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            vedavathi
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 20h
              20h
              Remaining:
              Remaining Estimate - 20h
              20h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development