ActiveMQ
  1. ActiveMQ
  2. AMQ-2163

ActiveMQEndpointWorker could not stop quickly with a incorrect connector ip/port setting on AIX platforms

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 4.1.2
    • Fix Version/s: 5.x
    • Component/s: None
    • Labels:
      None
    • Environment:

      AIX 6.1

      Description

      If the incorrect connector ip/port is set, on AIX platform, it takes a long time to stop it.
      While in windows machines, it behaviors much better. From the code, there is no explict deadlock, I think that it is may be caused by the different thread scheduler on different OS platforms. Anyway, I try to add a flag in the code, it will make the ActiveMQEndpointWorker stop quickly.
      Please help to review the patch, thanks !

        Activity

        Timothy Bish added a comment -

        The patch is no longer applicable to the current code as much has changed in this class.


          People

          • Assignee:
            Unassigned
            Reporter:
            Ivan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development