ActiveMQ
  1. ActiveMQ
  2. AMQ-2001

JMX: QueueView.getMessage(messageId) returns null on valid messageId

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.1.0
    • Fix Version/s: NEEDS_REVIEW
    • Component/s: JMX
    • Labels:
      None
    • Environment:

      Windows XP SP2, JDK 6 update 10

      Description

      I am trying to use JConsole to get a specific message from one of my queues and I always get null...
      Steps to reproduce the issue:

      1. Start AMQ web console.
      2. Create a new queue "test";
      3. Send a text message to the queue.
      4. Copy the message ID from browser.
      5. Open JConsole, select AMQ JVM
      6. Browse to MBeans > Queue > test > Operations
      7. Paste the message ID in the textbox next to getMessage and press the button to invoke the method.

      Expected result: the message in full details
      Actual result: null

      Note: getMessage works fine though in the following scenario:
      1. Use JConsole to invoke sendTextMessage on the "test" queue.
      2. A new message ID is returned; copy it;
      3. Invoke getMessage using the new message ID; the message is returned, as expected
      Afterwards:
      4. Refresh the web page, so the new message is now visible
      5. Invoke getMessage with the same message ID; the method returns null;
      So as long as I don't touch the web browser, getMessage works...

        Activity

        Suiden created issue -
        Rob Davies made changes -
        Field Original Value New Value
        Fix Version/s 5.4.0 [ 12110 ]
        Rob Davies made changes -
        Fix Version/s NEEDS_REVIEWED [ 12186 ]
        Fix Version/s 5.4.0 [ 12110 ]
        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Timothy Bish added a comment -

        Followed the steps as described, getMessage worked fine.

        Timothy Bish made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        968d 10h 52m 1 Timothy Bish 08/Jul/11 22:53

          People

          • Assignee:
            Unassigned
            Reporter:
            Suiden
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development