ActiveMQ
  1. ActiveMQ
  2. AMQ-1982

can't start AMQ 5.2.0RC2 on windows

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.0
    • Fix Version/s: 5.2.0
    • Component/s: Broker
    • Labels:
      None
    • Environment:

      Windows XP SP2. Sun java version "1.6.0_02"

      Description

      I just downloaded apache-activemq-5.2.0-bin.zip dated 07-Oct-2008 17:12 from http://people.apache.org/~gtully/staging-repos/activemq-5.2.0/org/apache/activemq/apache-activemq/5.2.0/ and, after unpacking, it fails to start on my XP SP2 box. Output as below:

      ACTIVEMQ_HOME: D:\Development\activemq\apache-activemq-5.2.0\bin\..
      ACTIVEMQ_BASE: D:\Development\activemq\apache-activemq-5.2.0\bin\..
      Loading message broker from: xbean:activemq.xml
      ERROR: java.lang.RuntimeException: Failed to execute start task. Reason: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      java.lang.RuntimeException: Failed to execute start task. Reason: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:98)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:129)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:79)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.activemq.console.Main.runTaskClass(Main.java:225)
      at org.apache.activemq.console.Main.main(Main.java:106)
      Caused by: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:78)
      at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:554)
      at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:528)
      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:363)
      at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:64)
      at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:52)
      at org.apache.activemq.xbean.XBeanBrokerFactory.createApplicationContext(XBeanBrokerFactory.java:96)
      at org.apache.activemq.xbean.XBeanBrokerFactory.createBroker(XBeanBrokerFactory.java:52)
      at org.apache.activemq.broker.BrokerFactory.createBroker(BrokerFactory.java:71)
      at org.apache.activemq.broker.BrokerFactory.createBroker(BrokerFactory.java:54)
      at org.apache.activemq.console.command.StartCommand.startBroker(StartCommand.java:115)
      at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:74)
      ... 10 more
      Caused by: java.net.UnknownHostException: D
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:518)
      at java.net.Socket.connect(Socket.java:468)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.NetworkClient.openServer(NetworkClient.java:118)
      at sun.net.ftp.FtpClient.openServer(FtpClient.java:488)
      at sun.net.ftp.FtpClient.openServer(FtpClient.java:475)
      at sun.net.www.protocol.ftp.FtpURLConnection.connect(FtpURLConnection.java:270)
      at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:352)
      at org.springframework.core.io.UrlResource.getInputStream(UrlResource.java:123)
      at org.springframework.core.io.support.PropertiesLoaderSupport.loadProperties(PropertiesLoaderSupport.java:182)
      at org.springframework.core.io.support.PropertiesLoaderSupport.mergeProperties(PropertiesLoaderSupport.java:161)
      at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:69)
      ... 21 more
      ERROR: java.lang.Exception: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      java.lang.Exception: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:99)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.runTask(ShellCommand.java:129)
      at org.apache.activemq.console.command.AbstractCommand.execute(AbstractCommand.java:57)
      at org.apache.activemq.console.command.ShellCommand.main(ShellCommand.java:79)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.activemq.console.Main.runTaskClass(Main.java:225)
      at org.apache.activemq.console.Main.main(Main.java:106)
      Caused by: org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.net.UnknownHostException: D
      at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:78)
      at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:554)
      at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:528)
      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:363)
      at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:64)
      at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:52)
      at org.apache.activemq.xbean.XBeanBrokerFactory.createApplicationContext(XBeanBrokerFactory.java:96)
      at org.apache.activemq.xbean.XBeanBrokerFactory.createBroker(XBeanBrokerFactory.java:52)
      at org.apache.activemq.broker.BrokerFactory.createBroker(BrokerFactory.java:71)
      at org.apache.activemq.broker.BrokerFactory.createBroker(BrokerFactory.java:54)
      at org.apache.activemq.console.command.StartCommand.startBroker(StartCommand.java:115)
      at org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:74)
      ... 10 more
      Caused by: java.net.UnknownHostException: D
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:518)
      at java.net.Socket.connect(Socket.java:468)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.NetworkClient.openServer(NetworkClient.java:118)
      at sun.net.ftp.FtpClient.openServer(FtpClient.java:488)
      at sun.net.ftp.FtpClient.openServer(FtpClient.java:475)
      at sun.net.www.protocol.ftp.FtpURLConnection.connect(FtpURLConnection.java:270)
      at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:352)
      at org.springframework.core.io.UrlResource.getInputStream(UrlResource.java:123)
      at org.springframework.core.io.support.PropertiesLoaderSupport.loadProperties(PropertiesLoaderSupport.java:182)
      at org.springframework.core.io.support.PropertiesLoaderSupport.mergeProperties(PropertiesLoaderSupport.java:161)
      at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:69)
      ... 21 more

      Sounds like a path issue? See http://www.mail-archive.com/users@maven.apache.org/msg09111.html

      I also tried downloading the .tar.gz and trying that in cygwin but same result

        Activity

        Jerry Shea added a comment -

        This seems to be because of the malformed URL resulting from the below stanza in activemq.xml:

        <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
        <property name="locations">
        <value>file://$

        {activemq.base}/conf/credentials.properties</value>
        </property>
        </bean>

        If you add another slash after file: then the broker starts:

        <value>file:///${activemq.base}

        /conf/credentials.properties</value>

        Jerry Shea added a comment -

        Note that the same fix also needs to be applied to webapps\admin\WEB-INF\webconsole-embedded.xml

        Jerry Shea added a comment -

        same problem and same fix in 5.3.SNAPSHOT

        Gary Tully added a comment -

        good catch: changes applied to r706164

        thanks.

        Gary Tully added a comment -

        These fixes will now make 5.2.0 rc3


          People

          • Assignee:
            Gary Tully
            Reporter:
            Jerry Shea
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development