ActiveMQ
  1. ActiveMQ
  2. AMQ-1896

>1 transactional and exclusive consumers receiving messages at the same time.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.1.0
    • Fix Version/s: NEEDS_REVIEW
    • Component/s: Broker
    • Labels:
      None
    • Environment:

      Description

      With an env as described above it is possible to violate the exclusive consumer limitation. Initially with all three consumers being started and the producer sending messages, the exclusive consumer feature works fine.
      However if you kill and restart each consumer in a row, allowing another consumer to take over, you will eventually reach a state where a newly started consumer that should not be allowed to receive messages (as another active consumer already has the exclusive right) will also start receiving messages. Typically the msg numbers it receives are of higher numbers than those to be delivered next (e.g. exclusive consumer receives msg number 500 while new consumer receives msg number 1500).
      So this bug violates:

      • having just one exclusive consumer at any time
      • delivering all msgs in order.

      I could not reproduce this problem using the default AMQ store.

      1. HelloWorldJMS_ART-1896.zip
        13 kB
        Torsten Mielke
      2. AMQ-1896-JUnit.zip
        14 kB
        Torsten Mielke

        Activity

        Torsten Mielke added a comment -

        Use this testcase and follow the steps in README_ART-1896.txt

        Torsten Mielke added a comment -

        Attaching testcase in JUnit format. Follow instructions in README.txt.

        Timothy Bish added a comment -

        Ran the tests against the latest broker SNAPSHOT and the test passes every time.


          People

          • Assignee:
            Unassigned
            Reporter:
            Torsten Mielke
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development