ActiveMQ
  1. ActiveMQ
  2. AMQ-1495

support the hot-reload of new EIP routing rules in Java

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 5.0.0
    • Fix Version/s: NEEDS_REVIEW
    • Component/s: None
    • Labels:
      None

      Description

      If we deploy routing rules into, say, lib/rules we should auto-detect jar file changes and auto-reload the routing rules so that the EIP rules can be totally dynamic without having to bounce the broker.

        Issue Links

          Activity

          Claus Ibsen added a comment -

          Use a container that supports hot-reload etc.

          james strachan added a comment -

          One solution to the problem is just to reuse the ServiceMix 4 Runtime which supports auto-reloading of OSGi bundles in jar or expanded form.

          We could make the ActiveMQ broker use the ServiceMix Runtime so Camel rules can be easily hot deployed and redeployed as folks change the Java / Spring XML

          james strachan added a comment -

          Similar kind of issue - though CAMEL-234 is about XML rules whereas this issue is about Java rules


            People

            • Assignee:
              Unassigned
              Reporter:
              james strachan
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development