ActiveMQ
  1. ActiveMQ
  2. AMQ-1176

Using temporary destination across a nework of broker not reliable.

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.0
    • Fix Version/s: 4.1.1, 5.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Using temporary destinations across a network of broker can lead to some message not getting delivered due to the way that a temporary destination must first exist on a broker before it accepts a message for it. Due to the timing of some network events, the message may get sent to the destination slightly ahead of the event that creates the temporary destination.

        Activity

        Hiram Chirino created issue -
        Hiram Chirino added a comment -

        This timing issue also extends out to the JMS clients that will get a JMS exception stating that the destination does not exist yet due to the create event not having been received yet.

        Hiram Chirino added a comment -

        Fixed in http://svn.apache.org/viewvc?view=rev&revision=511082 in the 4.1 branch.

        You can avoid getting the 'destination does not exist yet exception' by disabling watchTopicAdvisories feature on the ActiveMQConnectionFactory.

        Jonas Lim added a comment -

        ported fix to trunk : r514754

        Jonas Lim made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 4.2.0 [ 11712 ]
        Jörg Henne made changes -
        Link This issue is related to AMQ-2214 [ AMQ-2214 ]
        Jörg Henne added a comment -

        AMQ-2214 might be a regression of AMQ-1176.

        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        6d 23h 34m 1 Jonas Lim 05/Mar/07 18:05

          People

          • Assignee:
            Hiram Chirino
            Reporter:
            Hiram Chirino
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development